Using gnuplot on Windows 7 64 bit

Help
2012-07-10
2014-07-07
  • Brian P. Wilfley

    Hi all,

    I downloaded and unpacked the 64-bit version of Reduce: reduce-windows64-20110414. I unpacked and put the directory in:

    c:\Tools\reduce-windows64-20110414\

    My PATH has: ;c:\Tools\reduce-windows64-20110414; near the front.

    I can run reduce just fine, but when I try creating a plot, I get:

    1: load_package "gnuplot";

    2: plot( sin(x));

    +++ Error unable to establish pipe: "gnuplot"

    I don't know what to do…

    Thanks for your help.

    Brian

     
  • Joseph Eagar

    Joseph Eagar - 2014-07-07

    Did anyone ever figure this out?

    Thanks!
    Joe

     
    • Arthur Norman

      Arthur Norman - 2014-07-07

      On Mon, 7 Jul 2014, Joseph Eagar wrote:

      Did anyone ever figure this out?

      Thanks!
      Joe

      I had failed to pick up on this when you first raised it - apologies. I
      just tried with a version of Reduce built from subversion and also gnuplot
      failed to start - however when I copied all the material from
      trunk/csl/support-packages/gnuplot-windows-bin into the directory where my
      reduce executable was things perked up usefully.

      When we get to providing a nicel installation package it will be able to
      set up gnuplot too automagically (I hope) but the snapshots maybe avoid
      including copies of packages provided by others - and the code within
      Reduce is not clever enough to scour your system and guarantee to find
      what it needs. See the code find_gnuplot on trunk/csl/cslbase/print.c
      that starts by saying if you have an environment variable GNUPLOT that
      says where to look, and then it tried polling the Windows registry where I
      had expected a properly installed gnuplot would have registered itself ...

      Feel free to check that code and investgate why it might not have worked
      in your paticular case!

      Arthur

      Using gnuplot on Windows 7 64 bit

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks