Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Mumble does not work with Guild Wars 2

Help
Arpem
2012-09-25
2013-01-08
  • Arpem
    Arpem
    2012-09-25

    Is it possible, if not already being worked on, to add overlay support to
    Guild Wars 2? Just used the dependency walker as suggested from a previous
    response, and found the GW2 supports both D3D9 and D3D10. However in the
    current snapshot it only has a plugin that supports Guild Wars. There is a
    workaround to get the overlay to work with GW2 but I dont like the approach
    for it.

     
  • Nicos Gollan
    Nicos Gollan
    2012-09-26

    Would the workaround be disabling D3D9Ex?

     
  • Nicos Gollan
    Nicos Gollan
    2012-09-26

    Alright, GW2 does not use D3D9Ex (at least not yet, apparently it caused
    problems so they switched back).

    The workaround involves circumventing the launcher, so the next suspicion
    would be that the overlay hooks break on the transition between that and the
    actual game.

     
  • Lamplighter
    Lamplighter
    2012-10-25

    i can atest that circumventing the launcher works just fine. overlay works
    great.

    there is no risk, unless someone logs into your computer and steals your
    shortcut.

    Add this to the end of the TARGET section on the properties window of your
    shortcut.
    -email EMAIL -password PASS -nopatchui

    EMAIL = your login email address
    PASSWORD = your login password.

    again, these help the gw2.exe circumvent the launcher (where you would
    normally type those items in), there is no security risk with this method. and
    it works.

    Cheers,
    Lamplighter.

     
  • James Orr
    James Orr
    2013-01-08

    This does work, but as of a patch a month or two ago you can no longer use the trading post if you login with this method (you get authentication errors).

    Is there any work being done to address this issue so the work-around is not required? Most other overlays seem to work fine with Guild Wars 2.