You can subscribe to this list here.
| 2001 |
Jan
|
Feb
|
Mar
|
Apr
|
May
|
Jun
|
Jul
|
Aug
|
Sep
(55) |
Oct
(44) |
Nov
(156) |
Dec
(123) |
|---|---|---|---|---|---|---|---|---|---|---|---|---|
| 2002 |
Jan
(130) |
Feb
(156) |
Mar
(162) |
Apr
(171) |
May
(97) |
Jun
(127) |
Jul
(58) |
Aug
(81) |
Sep
(86) |
Oct
(45) |
Nov
(41) |
Dec
(84) |
| 2003 |
Jan
(71) |
Feb
(87) |
Mar
(133) |
Apr
(152) |
May
(151) |
Jun
(232) |
Jul
(320) |
Aug
(237) |
Sep
(271) |
Oct
(536) |
Nov
(301) |
Dec
(393) |
| 2004 |
Jan
(393) |
Feb
(184) |
Mar
(314) |
Apr
(225) |
May
(139) |
Jun
(77) |
Jul
(87) |
Aug
(75) |
Sep
(139) |
Oct
(50) |
Nov
(8) |
Dec
(28) |
| 2005 |
Jan
(66) |
Feb
(63) |
Mar
(14) |
Apr
(14) |
May
(8) |
Jun
(23) |
Jul
(21) |
Aug
(6) |
Sep
(29) |
Oct
(55) |
Nov
(38) |
Dec
(8) |
| 2006 |
Jan
(5) |
Feb
(10) |
Mar
(1) |
Apr
(15) |
May
(32) |
Jun
(44) |
Jul
(11) |
Aug
(8) |
Sep
(9) |
Oct
(14) |
Nov
(4) |
Dec
(3) |
| 2007 |
Jan
(3) |
Feb
(3) |
Mar
(2) |
Apr
|
May
|
Jun
|
Jul
(35) |
Aug
(49) |
Sep
(8) |
Oct
(42) |
Nov
(44) |
Dec
(7) |
| 2008 |
Jan
(2) |
Feb
(7) |
Mar
(8) |
Apr
(80) |
May
(74) |
Jun
(29) |
Jul
(5) |
Aug
(7) |
Sep
(6) |
Oct
(1) |
Nov
|
Dec
|
| 2009 |
Jan
(8) |
Feb
(19) |
Mar
(3) |
Apr
(24) |
May
(22) |
Jun
(23) |
Jul
(8) |
Aug
(23) |
Sep
(8) |
Oct
(27) |
Nov
(52) |
Dec
(27) |
| 2010 |
Jan
(36) |
Feb
(29) |
Mar
(17) |
Apr
(28) |
May
(21) |
Jun
(4) |
Jul
|
Aug
(28) |
Sep
(18) |
Oct
(6) |
Nov
(34) |
Dec
(16) |
| 2011 |
Jan
(18) |
Feb
(12) |
Mar
|
Apr
|
May
(9) |
Jun
(1) |
Jul
(5) |
Aug
(5) |
Sep
(7) |
Oct
(16) |
Nov
(26) |
Dec
(17) |
| 2012 |
Jan
(6) |
Feb
(34) |
Mar
(52) |
Apr
(10) |
May
(3) |
Jun
|
Jul
|
Aug
(1) |
Sep
|
Oct
(4) |
Nov
(1) |
Dec
(4) |
| 2013 |
Jan
(5) |
Feb
|
Mar
|
Apr
(5) |
May
(4) |
Jun
|
Jul
|
Aug
(14) |
Sep
|
Oct
|
Nov
|
Dec
|
| 2014 |
Jan
|
Feb
(2) |
Mar
(5) |
Apr
|
May
|
Jun
|
Jul
|
Aug
|
Sep
|
Oct
|
Nov
(3) |
Dec
(11) |
| 2015 |
Jan
(5) |
Feb
|
Mar
|
Apr
|
May
|
Jun
|
Jul
|
Aug
(1) |
Sep
(1) |
Oct
(1) |
Nov
|
Dec
|
| 2016 |
Jan
|
Feb
|
Mar
|
Apr
|
May
|
Jun
(2) |
Jul
|
Aug
|
Sep
|
Oct
|
Nov
|
Dec
|
| 2017 |
Jan
(1) |
Feb
|
Mar
|
Apr
|
May
|
Jun
|
Jul
|
Aug
|
Sep
|
Oct
|
Nov
|
Dec
|
| 2018 |
Jan
(2) |
Feb
|
Mar
|
Apr
|
May
|
Jun
|
Jul
|
Aug
|
Sep
|
Oct
|
Nov
|
Dec
|
|
From: Dean N. <di...@ti...> - 2003-08-28 20:01:09
|
I did some checking on the poweroff (or the lack there of) issue that I am having. o Poweroff is done by a call to the /sbin/halt at system shutdown via the /etc/init.d/halt command procedure. Power off is accomplished by using the -p option (which we are using). o One of the other options to /sbin/halt that we are NOT using and probably should consider is -h. It tells the system to spin down the disks and flush the disk cache. (Remember, we are talking about halt and poweroff here, not reboot). o A check of the web indicated that I either need the "apm" module to load (and specify modprobe apm power_off=1 or placing apm power_off=1 in /etc/modules - though that doesn't seem to match our configuration), or to specify "apm=on apm=power_off" as part of the boot. (A good web page on that is: http://www.togaware.com/linux/survivor/APM_Power.html ) o I need APM over ACPI because my motherboard is pre-2000. Unrelated, but I think I know why the lspci command is not working properly. 'man lspci' says that it uses /usr/share/pci.ids (which is where we have the file). However, 'lspci -h' (i.e., asking the utility itself) indicates that the file is /usr/local/share/pci.ids. So, either the utility was compiled wrong, or we need to move the file! :-) Dean Nedelman TimeLord Consulting |
|
From: Heiko Z. <hz...@pr...> - 2003-08-28 19:47:15
|
On 08/28/2003 03:01:15 PM Bruce Smith wrote: >> Yeah, even you should understand it. *lol* >> (sorry, couldn't resist). > >It's sure nice to have the develop list working again. >I don't have to wait so long for the insults! ;-) Yeah, isn't that great ? *lol* = |
|
From: Heiko Z. <hz...@pr...> - 2003-08-28 19:36:37
|
On 08/28/2003 03:22:03 PM Bruce Smith wrote: >I've learned (the hard way) to watch closely for these errors when >updating source. ;-) > >mirror: Access failed: 550 gnupg-1.2.3.tar.bz2: Permission denied >mirror: Access failed: 550 man-pages-1.60.tar.bz2: Permission denied > >(all fixed now) Thanks, I always forgett to check it. Heiko = |
|
From: Bruce S. <bw...@ar...> - 2003-08-28 19:22:05
|
I've learned (the hard way) to watch closely for these errors when updating source. ;-) mirror: Access failed: 550 gnupg-1.2.3.tar.bz2: Permission denied mirror: Access failed: 550 man-pages-1.60.tar.bz2: Permission denied (all fixed now) - BS |
|
From: Bruce S. <bw...@ar...> - 2003-08-28 19:01:24
|
> Yeah, even you should understand it. *lol* > (sorry, couldn't resist). It's sure nice to have the develop list working again. I don't have to wait so long for the insults! ;-) - BS |
|
From: <no...@fr...> - 2003-08-28 06:57:24
|
This email is to inform you about the release of version '2.10.1' of 'distcc' through freshmeat.net. All URLs and other useful information can be found at http://freshmeat.net/projects/distcc/ The changes in this release are as follows: A small Makefile bug was fixed. Project description: distcc is a parallel build system that distributes compilation of C/C++/ObjC code across machines on a network. It can be set up in just a few minutes and makes builds up to ten times faster. It does not require machines to share a filesystem or have the same libraries or header files, and installation does not need superuser privileges. If you would like to cancel subscription to releases of this project, login to freshmeat.net and choose 'home' from the personal menubar at the top of the page. You'll be presented with a list of projects you're subscribed to in the right column, which you may cancel by highlighting the project in question and clicking the 'delete' button. Sincerely, freshmeat.net ____________________________| Advertising |____________________________ 17th Systems Administration Conference (LISA 2003) October 26-31, 2003 - San Diego, CA USA The Conference For and By Sysadmins - Sponsored by USENIX & SAGE - Meet, learn, & exchange ideas on every aspect of computer and network management. Don't miss out! Receive an additional discount when you register online. http://www.usenix.org/events/lisa2003 ____________________________| Advertising |____________________________ |
|
From: Bruce S. <bw...@ar...> - 2003-08-28 02:31:45
|
> - Firewall.rules.2nic has a bug: it has a hard coded reference to /bin/echo I noticed that yesterday, and fixed it earlier today in CVS. > - the "Setting up ROLF/F" message that I get on the console, showed up > instead on the SYSLOG output (F10) when I used the above mentioned setup. > - The setup program didn't set the interface modules correctly, but that > may have been "operator error" (it is possible I may have scrolled down but > not hit "OK" or something like that). I can't duplicate it either. If you find a way to duplicate it consistently, please let me know. My guess is operator error. You have to be careful with a selection screen like that. You cannot just move the cursor to the module and press ENTER. You have to move the cursor, press SPACE to select the module, and then press ENTER. I've made that mistake before myself. Plus you want to double check it changed when you return to the parent screen. Current selections are displayed in [brackets]. - BS |
|
From: Bruce S. <bw...@ar...> - 2003-08-28 02:25:46
|
> Let's just fix our memory requirement at 32 MB. > Lower requirements are something for eDL. Agree. 32MB is fine. - BS |
|
From: Heiko Z. <he...@zu...> - 2003-08-28 02:10:14
|
Bruce Smith wrote: >>>It would be easy to hack the linuxrc startup script, and say if >>>/cdrom/config/etc-static.tar.gz2 exists, then completely ignore the >>>floppy and USB devices, and ONLY untar the static etc file from CD. >> >>I like this idea, too. >>It will work only with IDE CD-ROMs . > > > Good point. > > Speaking of CD drives, I installed the latest DL on a PC with a SCSI CD > drive for the first time yesterday. I started out with a blank floppy. > It booted, ask if I wanted to copy the config to floppy (I said "y"), > and it ask if I wanted to probe for SCSI controllers. Again I said "y". > And ... PUKE! :-) It couldn't find any SCSI modules. > > Are any SCSI modules available to the boot script at that time now? > Or have they all been removed to save memory? Or have they moved? > > If they've been removed, we might as well remove the code (and question) > for probing for SCSI. I fixed some of the problems with the SCSI detection, but it's not completely fixed. The script has problems with the creation of the file /dev/shm/.probed_modules Unfortunately I don't have more time to look into this and I'm away this weekend. But I'm confident that Bruce can fix it. ;-) cya Heiko |
|
From: Heiko Z. <he...@zu...> - 2003-08-28 01:45:30
|
Bruce Smith wrote: > I had a weird thing this morning while running save-config, where it > aborted in a very strange way (in VMware). To make a long story short, > after a lot of traces, manual "tar" commands, and head beating, I > figured out it was because my VMware was set to 16MB of memory. > > This is a fresh boot with a blank floppy. It seems like there is enough > memory in 16MB to run tar, but when the "j" option kicks in, bzip2 loads > and aborts tar. > > I increased my memory in VMware to 32MB and save-config runs fine there > (except for the "diff" part which I don't care about). > > We might want NOT want to advertise DL will run in 16MB of memory, if > people cannot save their configuration on that size machine. The other > option would be to use some busybox commands in save-config instead of > the standard ones ... (or not :) Let's just fix our memory requirement at 32 MB. Lower requirements are something for eDL. cya Heiko |
|
From: Heiko Z. <he...@zu...> - 2003-08-28 01:05:32
|
Dean Nedelman wrote: >>On 08/27/2003 03:25:14 AM "Dean Nedelman" wrote: >> >>>Heiko Zuerker wrote: >>> >>>>Dean Nedelman wrote: >>>> >>>>>still getting a grsec error: >>>>>grsec: attempted resource overstep by requesting 92786688 for >> >>RLIMIT_STACK >> >>>>>against limit 8388608 by (pidof:385) UID(0) EUID(0), parent >> >>(S05network:373) >> >>>>>UID(0) EUID(0) >>>>> >>>>>I -believe- this is related to my dhcpcd.exe script - which uses >> >>pidof. >> >>>>That is really strange. >>>>Can you try it with a "clean" setup? I mean empty floppy and >> >>configuring >> >>>>the stuff via the setup program. >>>>How much RAM do you have in this machine? >>> >>>I have 64MB of ram. >> >>Then this can't be the root of the problem. > > > Ok, same problem. I get that grsec message when the default dhcpcd.exe is > executed. > > I started with a clean setup, ran setup and set the following items: > o Hostname > o Domain name > o Timezone > o ETH0 module > o ETH0 gets its IP address dynamically > o ETH1 module > o ETH1's static IP address > o Use Bruce's 2NIC firewall > > Rebooted, got the error. I did the same and can't reproduce your error, sorry. Does anybody else experiences a problem like this? > Couple of observations (for what its worth): > > - Firewall.rules.2nic has a bug: it has a hard coded reference to /bin/echo > - the "Setting up ROLF/F" message that I get on the console, showed up > instead on the SYSLOG output (F10) when I used the above mentioned setup. The ROL/F patch is removed and won't cause any further problems. > - The setup program didn't set the interface modules correctly, but that > may have been "operator error" (it is possible I may have scrolled down but > not hit "OK" or something like that). Work fine for me, so it looks like an operator error. cya Heiko |
|
From: SourceForge.net <no...@so...> - 2003-08-28 00:04:04
|
Bugs item #795695, was opened at 2003-08-26 18:46 Message generated for change (Comment added) made by smiley73 You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=410643&aid=795695&group_id=34096 Category: Base System Group: None >Status: Closed >Resolution: Fixed Priority: 7 Submitted By: Heiko Zuerker (smiley73) >Assigned to: Heiko Zuerker (smiley73) Summary: rol/f kernel patch causing problems Initial Comment: reported by Dean Nedelman > --- Problem 3 --- > get the following: (Note: The ethx: Setting... message is standard, > everything else is NEW!) > > eth0: Setting 100mbps full-duplex based on auto-negotiated partner ability > 41e1. > Setting up ROL/F > Setting up ROL/F > Setting up ROL/F > i8253 count too high! resetting.. > Setting up ROL/F > i8253 count too high! resetting... > > and also: > > eth1: Setting 100mbps full duplex based on auto-negotiated partner ability > 45e1. > Setting up ROLF/F > Setting up ROLF/F > Setting up ROLF/F > Setting up ROLF/F > > i8253 count too high! resetting... SHIT ! @Thomas this is the newly added ROL/F Patch, can you please investigate on it? Otherwise I'll have to remove it. ---------------------------------------------------------------------- >Comment By: Heiko Zuerker (smiley73) Date: 2003-08-27 19:04 Message: Logged In: YES user_id=112133 disabled patch ---------------------------------------------------------------------- You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=410643&aid=795695&group_id=34096 |
|
From: Dean N. <di...@ti...> - 2003-08-27 23:32:17
|
>On 08/27/2003 03:25:14 AM "Dean Nedelman" wrote: >>Heiko Zuerker wrote: >>>Dean Nedelman wrote: >>>> still getting a grsec error: >>>> grsec: attempted resource overstep by requesting 92786688 for >RLIMIT_STACK >>>> against limit 8388608 by (pidof:385) UID(0) EUID(0), parent >(S05network:373) >>>> UID(0) EUID(0) >>>> >>>> I -believe- this is related to my dhcpcd.exe script - which uses >pidof. >>> >>>That is really strange. >>>Can you try it with a "clean" setup? I mean empty floppy and >configuring >>>the stuff via the setup program. >>>How much RAM do you have in this machine? >> >>I have 64MB of ram. > >Then this can't be the root of the problem. Ok, same problem. I get that grsec message when the default dhcpcd.exe is executed. I started with a clean setup, ran setup and set the following items: o Hostname o Domain name o Timezone o ETH0 module o ETH0 gets its IP address dynamically o ETH1 module o ETH1's static IP address o Use Bruce's 2NIC firewall Rebooted, got the error. Couple of observations (for what its worth): - Firewall.rules.2nic has a bug: it has a hard coded reference to /bin/echo - the "Setting up ROLF/F" message that I get on the console, showed up instead on the SYSLOG output (F10) when I used the above mentioned setup. - The setup program didn't set the interface modules correctly, but that may have been "operator error" (it is possible I may have scrolled down but not hit "OK" or something like that). Dean |
|
From: Heiko Z. <hz...@pr...> - 2003-08-27 15:07:37
|
On 08/27/2003 08:32:14 AM Bruce Smith wrote: >> >The crontabs are kept in: /var/spool/cron/tabs/ >> >All crontabs are lost after a reboot. >> > >> >And, are there other files in /var worth saving? ... > >What about /var/spool/postfix/ ? (undelivered email queue?) >Do people who run postfix move /var to a read hard drive? I expect that everybody has his/her mails on the harddisk, not on a ramdisk. >> There's an easier solution: use /etc/crontab >> We probably should mention this in the documentaiton.... > >Ah, good point! Yeah Yeah cya Heiko = |
|
From: Heiko Z. <hz...@pr...> - 2003-08-27 15:07:08
|
On 08/27/2003 08:29:23 AM Bruce Smith wrote: >> > This is a fresh boot with a blank floppy. It seems like there is >enough >> > memory in 16MB to run tar, but when the "j" option kicks in, bzip2= >loads >> > and aborts tar. >> > >> > I increased my memory in VMware to 32MB and save-config runs fine >there >> > (except for the "diff" part which I don't care about). >> > >> > We might want NOT want to advertise DL will run in 16MB of memory,= >if >> > people cannot save their configuration on that size machine. The >other >> > option would be to use some busybox commands in save-config instea= d >of >> > the standard ones ... (or not :) >> >> Damned. Of course that was a function I didn't test. >> It's worth a try to use just for this function the busybox tar. > >Are the busybox binaries available on the CD somewhere? (where?) I can't verify it right now, but I think the binary is /bin/busybox Heiko = |
|
From: Heiko Z. <hz...@pr...> - 2003-08-27 15:07:07
|
On 08/27/2003 08:26:54 AM Bruce Smith wrote: >> > It would be easy to hack the linuxrc startup script, and say if >> > /cdrom/config/etc-static.tar.gz2 exists, then completely ignore th= e >> > floppy and USB devices, and ONLY untar the static etc file from CD= . >> >> I like this idea, too. >> It will work only with IDE CD-ROMs . > >Good point. > >Speaking of CD drives, I installed the latest DL on a PC with a SCSI C= D >drive for the first time yesterday. I started out with a blank floppy= . >It booted, ask if I wanted to copy the config to floppy (I said "y"), >and it ask if I wanted to probe for SCSI controllers. Again I said "y= ". >And ... PUKE! :-) It couldn't find any SCSI modules. > >Are any SCSI modules available to the boot script at that time now? >Or have they all been removed to save memory? Or have they moved? > >If they've been removed, we might as well remove the code (and questio= n) >for probing for SCSI. All the SCSI modules should be there. >> I would do it this way: check if conventional config media is >available, >> if not, check if we find a IDE CD-ROM with the config on it, if not,= >> *BEEP* BEEP* BEEP* Please insert blablabla > >I can't decide if it'd be best to check for media on CD or media first= . >They both have their advantages. Just implement one, you can switch it later if you don't like it. That's just a bit cut'n'paste. >> > How hard would it be to write a script that would read a DL CD (or= >ISO), >> > replace one file on it, and write a new ISO image? This script >would >> > need to run in a normal Linux distribution (Redhat/SuSE/...), not >from >> > the chroot development environment. >> >> I don't think that will be too hard, we (actually you) just need to >play >> around with the mkisofs/cdrecord tools. You also need to define a >> minimum version of the tool. > >I took a quick look at the build-iso script, and it shouldn't be too >hard to write such a script. Yeah, even you should understand it. *lol* (sorry, couldn't resist). cya Heiko = |
|
From: Bruce S. <bw...@ar...> - 2003-08-27 12:50:59
|
> >Out of curiosity, doesn't mount -auto "resolve" this problem (though I > >haven't actually tried it myself)? It is supposed to automatically > >determine the correct type. > > It should, but we still got some message. > Bruce was running into problems with the "-t auto", I don't know what > caused it. > @Bruce: can you try the "-t auto" again ? Yes, I'll take a look again. It is really strange. It worked in the first script, but failed in the second script. > >>> o I See that we have (again) moved a key binary - echo (from > >>> /bin/echo to /usr/bin/echo). > > That's unfortunately not always possible. The coreutils package for > example, replaced 3 other packages. > There are so many files included, you just don't see anymore what's going > on. If you really want to use the full path for echo in scripts, try this code which should work no matter what bin directory contains echo: ------------------------------------- ECHO=$(whereis -b echo|cut -d' ' -f2) # ... $ECHO message to display $ECHO another message # ------------------------------------- # OR # ------------------------------------- if [ -x /bin/echo ]; then ECHO=/bin/echo elif [ -x /usr/bin/echo ]; then ECHO=/usr/bin/echo else echo cannot find echo exit 1 fi # ... $ECHO message to display $ECHO another message # ------------------------------------- # OR # ------------------------------------- for e in $(echo $PATH | sed 's/:/ /g') do if [ -x "$e/echo" ]; then ECHO="$e/echo" break fi done # ... $ECHO message to display $ECHO another message # ------------------------------------- - BS |
|
From: Bruce S. <bw...@ar...> - 2003-08-27 12:32:17
|
> >The crontabs are kept in: /var/spool/cron/tabs/ > >All crontabs are lost after a reboot. > > > >And, are there other files in /var worth saving? ... What about /var/spool/postfix/ ? (undelivered email queue?) Do people who run postfix move /var to a read hard drive? > There's an easier solution: use /etc/crontab > We probably should mention this in the documentaiton.... Ah, good point! - BS |
|
From: Heiko Z. <hz...@pr...> - 2003-08-27 12:29:27
|
On 08/27/2003 03:25:14 AM "Dean Nedelman" wrote: >Heiko Zuerker wrote: >>Dean Nedelman wrote: >>> [Using the 08-23-i586-SMP release...] >>> NOTE: I am using ext2 on my floppy, and had no errors previously fo= r >the >>> betas. In fact, I had switched to ext from FAT so as to no longer >get the >>> error about being unable to find an ext2 file system on the floppy!= >(It >used >>> to look for ext2 first). >> >>That bug is still open: >>https://sourceforge.net/tracker/index.php?func=3Ddetail&aid=3D759801&= group_ >id=3D3 >4096&atid=3D410643 >>I agree that it is pretty anoying, I don't have a solution yet. > >Not really. Bug 759801 was when I had a FAT volume and it looked for >EXT2 >then FAT (and generated an error). To work around that bug, I had >switched >my floppy from FAT to EXT2. Now, by using EXT2, I'm back to getting a= >lot >of errors. (Hmmm, I wonder if I switch back to FAT whether they would= >go >away? :-) ). It's the same root-problem. >Out of curiosity, doesn't mount -auto "resolve" this problem (though I= >haven't actually tried it myself)? It is supposed to automatically >determine the correct type. It should, but we still got some message. Bruce was running into problems with the "-t auto", I don't know what caused it. @Bruce: can you try the "-t auto" again ? >>> --- Problem 2 ---- >>> still getting a grsec error: >>> grsec: attempted resource overstep by requesting 92786688 for >RLIMIT_STACK >>> against limit 8388608 by (pidof:385) UID(0) EUID(0), parent >(S05network:373) >>> UID(0) EUID(0) >>> >>> I -believe- this is related to my dhcpcd.exe script - which uses >pidof. >> >>That is really strange. >>Can you try it with a "clean" setup? I mean empty floppy and >configuring >>the stuff via the setup program. >>How much RAM do you have in this machine? > >I have 64MB of ram. Then this can't be the root of the problem. >I'll spend some time tomorrow afternoon with an empty floppy and see >what >happens. I'm presuming that you want me to do a "basic" setup using t= he >setup machine (network adaptor type, timezone, Bruce's firewall, setup= >as >DHCP client, etc.)? (i.e., DON'T setup postfix, DON'T setup my >firewall, >DON'T use my dhcpcd.exe file, etc.) Yes. Just configure it step by step so that we can find out when and wh= ere it happens. Otherwise it's hard to fix this problem. >>> --- Comment --- >>> o I See that we have (again) moved a key binary - echo (from >/bin/echo to >>> /usr/bin/echo). And before we get into another discussion about wh= y >I >have >>> hardcoded addresses for key executables in my firewall scripts: I >suppose >it >>> is for the same reason that Bruce uses them in -his- firewall >scripts! >> >>That's the new coreutils package, >>I modified the package so that everything is installed in /bin. It's >the >>"core" anyway. >>I will look more into problems which could come up with the new >package. > >I would be happy if we simply document when things move. That's unfortunately not always possible. The coreutils package for example, replaced 3 other packages. There are so many files included, you just don't see anymore what's goi= ng on. cya Heiko = |
|
From: Bruce S. <bw...@ar...> - 2003-08-27 12:29:25
|
> > This is a fresh boot with a blank floppy. It seems like there is enough > > memory in 16MB to run tar, but when the "j" option kicks in, bzip2 loads > > and aborts tar. > > > > I increased my memory in VMware to 32MB and save-config runs fine there > > (except for the "diff" part which I don't care about). > > > > We might want NOT want to advertise DL will run in 16MB of memory, if > > people cannot save their configuration on that size machine. The other > > option would be to use some busybox commands in save-config instead of > > the standard ones ... (or not :) > > Damned. Of course that was a function I didn't test. > It's worth a try to use just for this function the busybox tar. Are the busybox binaries available on the CD somewhere? (where?) > Can you take care of it? I have too many other things. I documented it > on SF. Sure. I'm going though a conversion at work now. Hopefully I can get to it this weekend or early next week. - BS |
|
From: Bruce S. <bw...@ar...> - 2003-08-27 12:27:00
|
> > It would be easy to hack the linuxrc startup script, and say if > > /cdrom/config/etc-static.tar.gz2 exists, then completely ignore the > > floppy and USB devices, and ONLY untar the static etc file from CD. > > I like this idea, too. > It will work only with IDE CD-ROMs . Good point. Speaking of CD drives, I installed the latest DL on a PC with a SCSI CD drive for the first time yesterday. I started out with a blank floppy. It booted, ask if I wanted to copy the config to floppy (I said "y"), and it ask if I wanted to probe for SCSI controllers. Again I said "y". And ... PUKE! :-) It couldn't find any SCSI modules. Are any SCSI modules available to the boot script at that time now? Or have they all been removed to save memory? Or have they moved? If they've been removed, we might as well remove the code (and question) for probing for SCSI. > I would do it this way: check if conventional config media is available, > if not, check if we find a IDE CD-ROM with the config on it, if not, > *BEEP* BEEP* BEEP* Please insert blablabla I can't decide if it'd be best to check for media on CD or media first. They both have their advantages. > > How hard would it be to write a script that would read a DL CD (or ISO), > > replace one file on it, and write a new ISO image? This script would > > need to run in a normal Linux distribution (Redhat/SuSE/...), not from > > the chroot development environment. > > I don't think that will be too hard, we (actually you) just need to play > around with the mkisofs/cdrecord tools. You also need to define a > minimum version of the tool. I took a quick look at the build-iso script, and it shouldn't be too hard to write such a script. - BS |
|
From: Heiko Z. <hz...@pr...> - 2003-08-27 12:24:56
|
On 08/26/2003 08:42:19 AM Bruce Smith wrote: >Back when I saw Heiko created another file: /cdrom/config/var.tar.bz2= >I "ass-umed" that we were going to tar up /var along with /etc, save i= t >to media, and restore them both upon boot. > >But I was wrong. Why would we ever need to save /var? All it has is >log files, run files, and stuff we don't need to save between reboots.= > >That's until I decided to create a crontab to modify my iptables >rules at different times of the day. :-) Guess what? Yup! >The crontabs are kept in: /var/spool/cron/tabs/ >All crontabs are lost after a reboot. > >Do I need to create a custom boot script that recreates the crontab fr= om >scratch on every boot? Or should we save some of the /var files in >etc.tar.bz2 or var.tar.bz2? Or should we sym-link /var/spool/cron to >/etc so they get saved? (or none of the above? :) > >And, are there other files in /var worth saving? ... There's an easier solution: use /etc/crontab We probably should mention this in the documentaiton.... cya Heiko = |
|
From: Dean N. <di...@ti...> - 2003-08-27 07:25:50
|
Heiko Zuerker wrote: >Dean Nedelman wrote: >> [Using the 08-23-i586-SMP release...] >> >> NOTE: My ISP's mail system is -way- behind schedule (and in fact has been >> down all day). So, if these problems have been reported before, except my >> apologies. >> >> --- Problem 1 ---- >> Unpacking Configuration >> FAT: bogus logical sector size 0 >> VFS: Can't find a valid FAT filesystem on dev 02:00. >> mount: wrong fs type, bad option, bad superblock on /dev/fd0, >> or too many mounted file systems >> Journalled Block Device driver loaded >> ext3: wrong fs type, bad option, bad superblock on /dev/fd0, >> or too many mounted file systems >> Unpacking /var >> >> NOTE: I am using ext2 on my floppy, and had no errors previously for the >> betas. In fact, I had switched to ext from FAT so as to no longer get the >> error about being unable to find an ext2 file system on the floppy! (It used >> to look for ext2 first). > >That bug is still open: >https://sourceforge.net/tracker/index.php?func=detail&aid=759801&group_id=3 4096&atid=410643 >I agree that it is pretty anoying, I don't have a solution yet. Not really. Bug 759801 was when I had a FAT volume and it looked for EXT2 then FAT (and generated an error). To work around that bug, I had switched my floppy from FAT to EXT2. Now, by using EXT2, I'm back to getting a lot of errors. (Hmmm, I wonder if I switch back to FAT whether they would go away? :-) ). Out of curiosity, doesn't mount -auto "resolve" this problem (though I haven't actually tried it myself)? It is supposed to automatically determine the correct type. >> --- Problem 2 ---- >> still getting a grsec error: >> grsec: attempted resource overstep by requesting 92786688 for RLIMIT_STACK >> against limit 8388608 by (pidof:385) UID(0) EUID(0), parent (S05network:373) >> UID(0) EUID(0) >> >> I -believe- this is related to my dhcpcd.exe script - which uses pidof. > >That is really strange. >Can you try it with a "clean" setup? I mean empty floppy and configuring >the stuff via the setup program. >How much RAM do you have in this machine? I have 64MB of ram. I'll spend some time tomorrow afternoon with an empty floppy and see what happens. I'm presuming that you want me to do a "basic" setup using the setup machine (network adaptor type, timezone, Bruce's firewall, setup as DHCP client, etc.)? (i.e., DON'T setup postfix, DON'T setup my firewall, DON'T use my dhcpcd.exe file, etc.) >> --- Comment --- >> o I See that we have (again) moved a key binary - echo (from /bin/echo to >> /usr/bin/echo). And before we get into another discussion about why I have >> hardcoded addresses for key executables in my firewall scripts: I suppose it >> is for the same reason that Bruce uses them in -his- firewall scripts! > >That's the new coreutils package, >I modified the package so that everything is installed in /bin. It's the >"core" anyway. >I will look more into problems which could come up with the new package. I would be happy if we simply document when things move. Thanks. Dean Nedelman TimeLord Consulting |
|
From: SourceForge.net <no...@so...> - 2003-08-27 02:28:31
|
Feature Requests item #496045, was opened at 2001-12-22 00:08 Message generated for change (Settings changed) made by smiley73 You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=410646&aid=496045&group_id=34096 Category: Base System Group: None >Status: Closed Priority: 7 Submitted By: Heiko Zuerker (smiley73) >Assigned to: Heiko Zuerker (smiley73) Summary: md5 support Initial Comment: enable md5 support needs to be enabled for several packages (e.g. openssh) needs to be enabled in /etc/login.defs ---------------------------------------------------------------------- You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=410646&aid=496045&group_id=34096 |
|
From: SourceForge.net <no...@so...> - 2003-08-27 00:58:16
|
Bugs item #759801, was opened at 2003-06-24 08:28 Message generated for change (Comment added) made by smiley73 You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=410643&aid=759801&group_id=34096 Category: Configuration / Scripts Group: None Status: Open Resolution: None Priority: 5 Submitted By: Heiko Zuerker (smiley73) Assigned to: Nobody/Anonymous (nobody) Summary: ext2/3 warning in initrd Initial Comment: >o When it went to unpack the floppy, it first checked for ext3, then >ext2, >then it mounted the floppy. Has the rules changed and are we supposed >to >use ext3/ext2 formatted floppies? [I am using FAT formatted floppies.] HIDE this warning. ---------------------------------------------------------------------- >Comment By: Heiko Zuerker (smiley73) Date: 2003-08-26 19:58 Message: Logged In: YES user_id=112133 a utility to detect and use the correct filesystem would solve this problem or a patch which get's rid of that stupid warning message ---------------------------------------------------------------------- You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=410643&aid=759801&group_id=34096 |