#970 Update LanguageTool to 3.3

4.0
open-fixed
5
2016-05-17
2014-03-09
cienislaw
No

LanguageTool bundled with Omega is outdated. It will be best to update it to latest version.

Related

Bugs: #812
Bugs: #814
Feature Requests: #1203
Feature Requests: #1249

Discussion

  • Didier Briel

    Didier Briel - 2014-03-12
    • assigned_to: cienislaw
     
    • Didier Briel

      Didier Briel - 2014-03-13

      Just to be sure: did you receive my last private message?

      Didier

       
  • Yu Tang

    Yu Tang - 2014-03-13

    I just noticed that changes.txt says "LanguageTool requires Java 7 now" at version 2.3.
    http://www.languagetool.org/download/CHANGES.txt

    Is that A-OK for OmegaT?

     
    • Didier Briel

      Didier Briel - 2014-03-13

      No it's not, I had missed that.
      (Thanks for noticing.)

      cienislaw, please check. If it is confirmed, we cannot force move to 1.7 now.

      Didier

       
  • cienislaw

    cienislaw - 2014-03-13

    yes, that's true. will wait for global update to 1.7 and for now I can update to latest LT supporting 1.6.

     
    • Didier Briel

      Didier Briel - 2014-03-13

      Fine.

      Didier

       
  • cienislaw

    cienislaw - 2014-03-13

    LanguageTool will be updated to 2.2. I will backup 2.4.1 release for future use. JUnit bundled with 2.2 is 4.7.

     
  • Didier Briel

    Didier Briel - 2016-03-15
    • summary: Update LanguageTool to latest version --> Update LanguageTool to 3.2
    • status: open --> open-fixed
    • assigned_to: cienislaw --> Aaron Madlon-Kay
    • Group: future --> 3.7
     
  • Aaron Madlon-Kay

    LanguageTool 3.2 uses a version of lucene-gosen-ipadic that is incompatible with Lucene 5 (discussion). I have manually replaced their JAR with a compatible one: lucene-gosen-5.0.0-ipadic.jar.

    Future upgrades of LanguageTool should keep the 5.0.0 JAR until LanguageTool starts bundling a compatible version.

     
  • Aaron Madlon-Kay

    • labels: languagetool, update --> languagetool, update, reminder
     
  • Aaron Madlon-Kay

    • labels: languagetool, update, reminder --> languagetool, update
     
  • Aaron Madlon-Kay

    • summary: Update LanguageTool to 3.2 --> Update LanguageTool to 3.3
     
  • Aaron Madlon-Kay

    After upgrading to 3.2 but before any releases we have already upgraded to 3.3, so I will rename this RFE.

     
  • Aaron Madlon-Kay

    • labels: languagetool, update --> languagetool, update, reminder
     
  • Aaron Madlon-Kay

    Re-adding the reminder tag (not sure why it got deleted).

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks