#109 0.8.1-3 freezes after touching tablet (ie. clicking)

closed-fixed
nobody
USB Tablet (38)
2015-12-04
2008-08-31
No

After installing X driver from 0.8.1-3 everything seems fine at start but after touching tablet with a pen (ie. clicking) no events are sent untill I move pen way away from tablet (ie. such distance that pen is no longer powered or whatever).

If I do cat /dev/input/event4 in console everything seems to work (ie. some text is sent after I click and move pen around).

My tablet is Bamboo. I'm suing X.Org X Server 1.4.2 (that's what X -version says) and Linux 2.6.26.2 with wacom module compiled in.

Everything is fine on 0.8.0-3. Wasn't able to compile 0.8.1-2.

Discussion

  • Ping Cheng

    Ping Cheng - 2008-09-02

    Logged In: YES
    user_id=754442
    Originator: NO

    Hey Michal, you are really living on the cutting edge (I mean 2.6.26 and 1.4.2). I'd like to resolve your issue if you still see the problem with 0.8.1-4. Please upgrade to 0.8.1-4 and let me know your result.

     
  • Michał “mina86” Nazarewicz

    Logged In: YES
    user_id=1023200
    Originator: YES

    Living on the edge is what brings sens to my life. ;) The bug is still present in 0.8.1-4.

     
  • Ping Cheng

    Ping Cheng - 2008-09-04

    Logged In: YES
    user_id=754442
    Originator: NO

    Email me the output of your compiling error so I can take a look.

     
  • Michał “mina86” Nazarewicz

    Logged In: YES
    user_id=1023200
    Originator: YES

    File Added: linuxwacom-0.8.1-2_building-log_20080904.gz

     
  • Michał “mina86” Nazarewicz

    Logged In: YES
    user_id=1023200
    Originator: YES

    I've just tested 0.8.1-1 -- it does not work neither.

     
  • Nobody/Anonymous

    I see the compiling bug with 0.8.1-2. It is fixed with 0.8.1-4. With 0.8.1-4, Do you mean you still see the compiling error or your system freezes? If your system freezes, please email me the last /var/log/Xorg.0.log with option "Commondbg" "12" and option "debuglevel" "12" added to you /etc/X11/xorg.conf.

    What Linux distribution are you running? I'd like to setup a system like yours to see the issue myself.

    Ping

     
  • David De La Harpe Golden

    I'm seeing this too with linuxwacom 0.8.1-4 , debian/unstable x86 packaged xorg 1.4.2 and linux kernel 2.6.26 . Wacom cintiq+partner, both affected. It's only the stylus tip or eraser i.e. "left"-button/button-1 that freezes the pointer, buttons 2 and 3 are unaffected. The effect is visible in xidump.

     
  • Michał “mina86” Nazarewicz

    Sorry it took so long, I was extremally busy lately.

    Attached is xorg.0.log.

    I'm using Slackware current with hand configured linux kernel.
    File Added: xorg.log.bz2

     
  • Tommy

    Tommy - 2008-10-25

    Hi, I also have this problem with my graphire bluetooth in ubuntu 8.10. Just want to add that the tablet works normally until pressure exceeds +00063 (out of a maximum of +00511), then it locks up. It's actually possible to use the tablet with very very light pressure.

    I'm using the same kernel driver that worked in hardy, and running wacdump outside of X reports the correct pressure information.

    linuxwacom 0.8.1-4
    linux kernel 2.6.27
    Xorg 1.5.2

     
  • Nobody/Anonymous

    I just installed linuxwacom version 0.8.1-6 and the tablet seems to be working fine now :)

     
  • Michał “mina86” Nazarewicz

    Same here. 0.8.1-6 seem to work fine. :)

     
  • Ping Cheng

    Ping Cheng - 2008-10-28

    I am going to close this bug since 0.8.1-6 fixes the issue reported.

     
  • Ping Cheng

    Ping Cheng - 2008-10-28
    • status: open --> closed-fixed
     
  • gatopeich

    gatopeich - 2011-09-13

    This bug seems to have resurfaced for me on Ubuntu 10.04 with the driver in kernel 2.6.32, and 2.6.38, and Xorg 1.7.6. On older Ubuntu I was working fine with compiled drivers from here, but now the tablet is supported off the shelf by Kernel and Xorg, and this bug is back.
    I'm still investigating the issue...

     
  • gatopeich

    gatopeich - 2011-09-17

    Re: "This bug seems to have resurfaced for me on Ubuntu 10.04"
    It is working fine with the standard drivers from Ubuntu. I had a problem for using a packet from a PPA, when it is not necessary anymore in Ubuntu since 10.04.

     

Log in to post a comment.