[Libki-Users] Upgrade failed
Brought to you by:
kylemhall
|
From: Sean C. <sea...@gm...> - 2026-06-24 06:50:21
|
I'm trying to upgrade a server from (actually, I'm not sure what version I
am on) on Ubuntu 20.04 to 26.05.02 on Ubuntu 22.04, but I get the following
error:
./installer/update_db.pl
You can only consume roles, Catalyst::TraitFor::Request::ProxyBase is not a
Moose role at /usr/lib/x86_64-linux-gnu/perl5/5.34/Class/MOP/Class.pm line
472
Class::MOP::Class::create_anon_class('Moose::Meta::Class',
'superclasses', 'ARRAY(0x5636bd2a7dd8)', 'roles', 'ARRAY(0x5636bf20a870)',
'cache', 1) called at
/usr/local/share/perl/5.34.0/MooseX/RelatedClassRoles.pm line 42
MooseX::RelatedClassRoles::__ANON__::SERIAL::1::apply_request_class_roles('Libki',
'Catalyst::TraitFor::Request::ProxyBase') called at
/home/libki/libki-server/lib/Libki.pm line 59
require Libki.pm at installer/update_db.pl line 15
main::BEGIN at /home/libki/libki-server/lib/Libki.pm line 0
eval {...} at /home/libki/libki-server/lib/Libki.pm line 0
Compilation failed in require at ./installer/update_db.pl line 15.
BEGIN failed--compilation aborted at ./installer/update_db.pl line 15
After updating the server to 22.04, libki failed to start, so I decided to
upgrade libki.
In my libki-server directory I did a git-pull, then git checkout r26.05.02.
I then ran ./installer/update_db.pl
And installed the various dependencies that were missing.
But now I get the error above.
Do I need to do a fresh install of the server?
Sean
|