#1793 PHPParser not installed

Boray Eris

Cannot start: java.lang.NoSuchMethodError: org.gjt.sp.util.IOUtilities.closeQuietly(Ljava/io/Reader;)V
Try updating to a newer version of the plugin.


  • Alan Ezust

    Alan Ezust - 2014-08-25

    Please update to PHPParser 2.0.2 and jEdit 5.1 or 5.2pre1. The problem is already fixed.

  • Alan Ezust

    Alan Ezust - 2014-09-25

    Apologies, the jEdit depend of 4.5.0 was too low for PHPParser 2.0.2, so that's why it doesn't work with jEdit 5.2pre1. It needs to be rebuilt against a newer jEdit. I published a release request for PHPParser 2.0.3. Until it is released,
    You can grab a copy from my own jars folder here:

  • WuJiayi

    WuJiayi - 2014-10-24

    PHPParser 2.0.3 and jEdit 5.2pre1
    osx 10.8.5 with java1.7.0.67

    I found this problem remains unsolved for me...

    But I find the following jar works:

  • Alan Ezust

    Alan Ezust - 2014-10-26
    • status: open --> pending-fixed
  • Alan Ezust

    Alan Ezust - 2014-10-26

    Apologies, it seems the closeQuietly conversions were incomplete, and I totally missed the problems because PHPParser works fine if you compile it against the same version of jEdit you are using, but these bianry breakages only happen when you build against an older version of jEdit.
    Anyway, I made a release request for 2.0.4 which should work against jEdit 5.1 and later.

  • Alan Ezust

    Alan Ezust - 2015-02-11
    • status: pending-fixed --> closed-fixed

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks