#868 saving on lion: FOUND THE PROBLEM

closed-fixed
nobody
None
5
2012-03-12
2012-02-22
Anonymous
No

Hi Christiaan!

I found the problem with saving on Lion !!!
In the System Preferences > Keyboard Shortcuts > Services when I have the "Open File in Skim" box checked and a keyboard shortcut set, then it creates the problem as I described previously.

This is really weird, but I'm happy that I know where it came from!

I had recreated my user profile and everything was fine until I turned that Service back on it screwed the save file mechanism — no idea why. Can you see if you can recreate it on your machine? When I turn it back off then there's no problem.

Jan

Discussion

  • I don't see that problem. And it makes no sense.

    Did you open the file using that service? And what shortcut are you using? Does it matter what shortcut you use? You only have it when you do have a shortcut set?

     

  • Anonymous
    2012-02-23

    Sorry, was away for the day.
    Yes, I agree, it doesn't make sense at all. But I have it :-(
    OK, it does not matter what shortcut I set I had cmd-ctrl-S but I also tried with Z and E and different modifiers and it's always the same. It DOES matter though if I use it for opening the file. It only appears if I use the shortcut for opening it. If I open the file using right-click and context menu or dragging the file onto Skim in the Dock the problem does not appear.

     
  • So basically you're saying that you get the problem whenever you open the file using the service? The shortcut should not be relevant, using the Services menu (with or without shortcut) would lead to the same problem, is that correct?

    And what was selected in which app when you used the service?

    Can you try the (new) test version again and see whether the problem is solved?

     

  • Anonymous
    2012-02-23

    Hi there!

    You got it! Yes, the new version did get rid of the problem! THANKS A LOT !

    And thanks for the awesome program !!!

    (BTW: Yes, whenever I used the Service it led to the problem. But you resolved it. So what was it in the end?)

     
  • A technical issue. Apparently on Lion from services it gets a file reference URL rather than a file path URL (i.e.a URL that tracks the file object rather than the path). When you save the old file is deleted in the process (to be replaced by a new file), and that file reference URL becomes invalid, because it's tracking a file object that no longer exists. This is a system bug, because file reference URLs are perfectly valid objects, so the system frameworks need to be able to deal with them properly rather than get themselves into serious problems.

     
    • status: open --> closed-fixed
     

  • Anonymous
    2012-02-23

    Ok, I see — I'm glad you resolved it though ...

    Thanks for your quick support!

     

  • Anonymous
    2012-02-23

    • status: closed-fixed --> open-fixed
     
    • status: open-fixed --> closed-fixed