#628 Segmentation fault if using gcj with -Xassembler

OTHER
closed
nobody
gcc (462)
out-of-date
Unreproducible
2013-01-21
2004-07-25
nlite
No

Hi!

If I create a file named for example 'aaa' with only a
newline ('echo. > aaa') and run gcj on it as follows:

gcj aaa -Xassembler --help

it crashes with a segmentation fault:

Die Anweisung in "0x77f645cc" verweist auf Speicher in
"0x6c626d65". Der Vorgang "written" konnte nicht auf
dem Speicher durchgeführt werden.

(The command at "0x77f645cc" couldn't write to memory
in "0x6c626d65").

Output of ld -v:
GNU ld version 2.15.90 20040222

Output of gcc -v:
Reading specs from D:/MinGW/bin/../lib/gcc/mingw32/3.4.
0/specs
Configured with: ../gcc/configure --with-gcc
--with-gnu-ld --with-gnu-as --host=mingw32
--target=mingw32 --prefix=/mingw --enable-threads
--disable-nls --enable-languages=c,c++,f77,ada,objc,
java --disable-win32-registry --disable-shared
--enable-sjlj-exceptions --enable-libgcj
--disable-java-awt --without-x --enable-java-gc=boehm
--disable-libgcj-debug --enable-interpreter
--enable-hash-synchronization
Thread model: win32
gcc version 3.4.0 (mingw special)

I'm using Windows XP Professional and following
packages:
gcc-core-3.4.0-20040501-1.tar.gz
gcc-java-3.4.0-20040501-1.tar.gz
binutils-2.15.90-20040222-1.tar.gz
mingw-runtime-3.3.tar.gz

Discussion

  • nlite
    nlite
    2004-07-25

    • priority: 5 --> 2
     
  • Danny Smith
    Danny Smith
    2004-07-28

    Logged In: YES
    user_id=11494

    Hi,

    I can't reproduce this. What program is segfaulting? I
    assumed it was ld because without a suffix on the file and no -
    xlang switch, gcc just passes it on to ld.

    Danny

     
  • nlite
    nlite
    2004-07-29

    Logged In: YES
    user_id=1069458

    gcj.exe is segfaulting. Remember i'm calling gcj -Xassembler
    --help. If i use gcc -Xassembler --help, it doesn't generate a
    segfault. It also doesn't generate one if I use Mohan's 3.5 build
    (http://www.thisiscool.com/gcc_mingw.htm, gcc version 3.5.0
    20040629 (experimental)). So this might be already fixed?

     
  • Danny Smith
    Danny Smith
    2004-07-29

    • milestone: 102880 --> Unreproducible
     
  • Danny Smith
    Danny Smith
    2004-07-29

    Logged In: YES
    user_id=11494

    What does this command show
    gcj nul.java -Xassembler --help -v

     
  • nlite
    nlite
    2004-07-30

    Logged In: YES
    user_id=1069458

    gcj nul.java -Xassembler --help -v
    crashes without any output, trying to write to memory at 0.
    Same when I add spaces around nul.java.
    Same when I use a file named 'aaa'.

     
  • Earnie Boyd
    Earnie Boyd
    2012-10-25

    • status: open --> closed-out-of-date
     
  • Earnie Boyd
    Earnie Boyd
    2013-01-21

    • status: closed-out-of-date --> closed
    • assigned_to: Danny Smith --> nobody
    • resolution: --> out-of-date
    • category: --> Unreproducible
    • milestone: Unreproducible --> OTHER