Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1226 gnuplot.texi fails to build

5.0
closed-accepted
nobody
5
2013-09-24
2013-03-26
No

Hi,

with the last stable version 4.6.2, the make on gnuplot.texi fails with the following error :
./gnuplot.texi:17653: raising the section level of @subsubsection which is too low

the error is in the @section "complete list of terminals" being followed by a @subsubsection (without a @subsection between).
The error has been seen on Arch linux x64 (GNU make version 3.82).

a patch is provided to change every faulty @subsubsection to @subsection but I don't know if it is what the author would have done.

Regards

1 Attachments

Discussion

  • Ulrich Müller
    Ulrich Müller
    2013-04-04

    gnuplot.texi is a generated file, so the fix should really be applied to doc2texi.el, see attached patch.

     
    • That would be the right thing to do (in fact that is what Arch official package does).
      But since I'm building a "minimal dependency" package (https://aur.archlinux.org/packages/gnuplot-nox/), I don't expect users to have emacs to rebuild from the .el file.

       
  • Also:
    /bin/sh /builddir/build/BUILD/gnuplot-4.6.1/missing --run makeinfo -I. ./gnuplot.texi --no-split --output=gnuplot.info
    ./gnuplot.texi:9193: warning: @ref should not appear in @uref

     
  • Ethan Merritt
    Ethan Merritt
    2013-07-03

    I have applied an expansion of Ulrich's patch to doc2texi.el
    *.trm HELP text level 1 -> 3 (subsection)
    level 2 -> 4 (subsubsection)
    The corresponding changes will show up in the version of gnuplot.texi included in the next release package.

     
  • Ethan Merritt
    Ethan Merritt
    2013-07-03

    • status: open --> pending-accepted
     
  • Ethan Merritt
    Ethan Merritt
    2013-09-24

    • status: pending-accepted --> closed-accepted