0.9.0 Release candidate 6

2009-10-29
2013-04-12
  • Dear FreeMind users, 

    with this release, we continue the series of release candidates for
    the final version 0.9.0. It fixes some important bugs.

    For translators may still update the translations to the current
    set of strings, which hasn't changed since RC3.

    For testers: we need *everybody* to do tests. From the simplest to the
    hardest (e.g. memory and performance tests using profilers).
    If you have time - join us and tell your results
    (in the open discussion forum or in the bugs section). 

    Best regards, 

    Chris 
           

    Changes:

    ===============================
    Changes made in FreeMind 0.9.0 RC 6
    ===============================
    *   Fixed: Plain text Long node gets corrupted (loses newlines) on drag *   http://sourceforge.net/tracker/?func=detail&aid=2844139&group_id=7118&atid=107118
    *   Fixed: Question before delete issued from the menu added
    *   Fixed: Message on status bar is cleared before save.
    *   Improved: Graphical layout of password dialog for encryption
    *   Improved: If a file exists in "File->Save as" the file dialog is repeated.
    *   We now create two different versions for Mac: for OSX 10.5 Rosetta, there is a different one.
      These versions differ only in the way, the JavaApplicationStub is handled (the Rosetta version
      takes a copy from my laptop, the other version uses a symbolic link to
      /System/Library/Frameworks/JavaVM.framework/Resources/MacOS/JavaApplicationStub)

    ===============================
    Changes made in FreeMind 0.9.0 RC 5
    ===============================
    * Fixed caret position during automatic save in notes window. (see https://sourceforge.net/forum/message.php?msg_id=7413407).
    * Disabled splash screen of SimplyHtml as this looks unusual. Nevertheless, many thanks to the authors of this important component.
    * Fixed: Map does not load with RC4 * https://sourceforge.net/tracker/?func=detail&atid=107118&aid=2797009&group_id=7118
    * Updated korean translation, now with correct ISO code. Thanks to the author.
    * Fixed license problem with xsd2jibx.jar. Replaced with own library compileXsd.jar with GPLv2+.
    * Long node editor uses zoomed fonts (the rich type editor are still unzoomed).
    * Fixed problems with  in node text.
    * Fixed some "Center node" problems
    * Fixed: Node marker disappears after exporting * https://sourceforge.net/tracker/?func=detail&atid=107118&aid=2813905&group_id=7118
    * Fixed some focus problems.
    * Integrated (thanks to the author): Typos in help Mind Map * https://sourceforge.net/tracker/?func=detail&atid=107118&aid=2805776&group_id=7118

     
  • Eric L.
    Eric L.
    2009-11-07

    Hello,

    FreeMind 0.9.0_RC6 has been packaged and can be pulled from:

        deb http://eric.lavar.de/comp/linux/debian/ experimental

    (see the [ for more details)

    Let me know how it works, the package has only been tested on Debian/sid, I'm interested in your experience with Ubuntu and other versions of Debian.

    Cheers, Eric

    PS: I hope to get this version of FreeMind officially into Debian. Cross fingers!

      : http://freemind.sourceforge.net/wiki/index.php/FreeMind_on_Linux](http://en.wikipedia.org/wiki/Special:Search?search=%5B1%5D+for+more+details%29%0A%0ALet+me+know+how+it+works%2C+the+package+has+only+been+tested+on+Debian%2Fsid%2C+I%27m+interested+in+your+experience+with+Ubuntu+and+other+versions+of+Debian.%0A%0ACheers%2C+Eric%0A%0APS%3A+I+hope+to+get+this+version+of+FreeMind+officially+into+Debian.+Cross+fingers%21%0A%0A++%5B1%5D%3A+%5Burl%5Dhttp%3A%2F%2Ffreemind.sourceforge.net%2Fwiki%2Findex.php%2FFreeMind_on_Linux%5B%2Furl%5D)

     
  • Hello
    It does work on Ubuntu 9.10!

    I installed version 0.7 from Ubuntu Software Center, then copied files from version 0.9.0 RC6.

    After updating execution rights (chmod a+x *) it seems OK.

     
  • illner
    illner
    2009-12-12

    If apt-get complains that the entry in /etc/apt/sources.list is invalid:
    just put a slash at the end of line:

        deb http://eric.lavar.de/comp/linux/debian/ experimental/

    After downgrading libjibx-java it works fine on (K)ubuntu 9.10.
    Thank you very much for packaging!

    regards,

    illner

     
  • Eric L.
    Eric L.
    2009-12-12

    In the mean time, you can use

        deb http://eric.lavar.de/comp/linux/debian/ ubuntu/

    the version there has been compiled against JiBX 1.1 and it works without downgrade.

    Eric