Remove deprecated context properties
[proposal] Make Staff_symbol::line_count public and use it when <line_positions>’s not needed</line_positions> https://codereview.appspot.com/576090043
Fix regtests (conditional should only apply to horizontal fingerings) https://codereview.appspot.com/567560043
programming error/segfault while omitting Fingering.stencil with fingeringOrientations set 'left
Yowza. Not good indeed. Thanks for catching this James, I should’ve paid more attention!
Doc: mention tuplet-slur in Changes and in NR 1.2.1.2 "Tuplets"
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=ee56da0f7a68cb6d6c5cd8531a566d81abdc5e59
Fix #5476: segfault when Fingering stencil set to #f. https://codereview.appspot.com/567560043
Use `oneline’ when there’s either no staff OR a one-line staff https://codereview.appspot.com/576090043
Fix #5964: MM Rests shouldn’t segfault when there’s no StaffSymbol. https://codereview.appspot.com/576090043
IIUC, the Multi_measure_rest_engraver now relies on line-positions to place the grob, hence the crash?
Duh. #0 Grob::internal_get_property(scm_unused_struct*) const (this=this@entry=0x0, sym=0x7fffe98e1ea0) at grob-property.cc:162 #1 0x0000000000595190 in Staff_symbol::line_positions(Grob*) (me=0x0) at staff-symbol.cc:113 #2 0x00000000005335d7 in Multi_measure_rest::church_rest(Grob*, Font_metric*, int, int, double) (me=me@entry=0xbaa270, musfont=musfont@entry=0xba0850, measure_count=measure_count@entry=1, mdl=<optimized out>, space=space@entry=0) at multi-measure-rest.cc:268 #3 0x0000000000533f65...
Multi_measure_rest_engraver segfaults when its context doesn’t include Staff_symbol_engraver.
Polyphony followed with a grace note isn’t beamed
Oops, git-cl reopened this issue instead of opening a new one. Bleh, that’s just a fairly minor doc patch so hopefully we can get it in without too much fuss :-)
Doc: mention tuplet-slur in Changes and in NR 1.2.1.2 "Tuplets" See issue #5567 for David Nalesnik’s original patch. Documenting why the bracket-visibility default behavior isn’t suited to tuplet-slurs allows me to explicitely point towards the relevant snippet for more clarity, and to add a couple of additional internal references. https://codereview.appspot.com/559930043
facepalm. I got mixed up in my temporary git branches again. Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=610f9d924a9d3403facbdb7aa344ab0277f70274
Documentation and regtests needed for external font files
n-th time’s the charm: pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=8b1785909543f6ecb97a962067e75bb97e2caec1
And this is what gdb has to say: Box::is_empty (this=this@entry=0x0, a=a@entry=Y_AXIS) at /lilypond/flower/include/drul-array.hh:47 47 T const &operator [] (Direction d) const I’m wondering if it isn’t another skyline problem; setting the Direction to up or down doesn’t segfault but setting it to a horizontal direction (either right or left) does. I thought this illegal stencil Box would be passed by the New_fingering_engraver, but of the two following snippets, only the first one triggers the bug:...
It’s even worse, it seems: as soon as there’s a cross-staff slur, nothing else (scripts, markups, whatever) can be encompassed in the skylines: %#(ly:set-option 'backend 'eps) #(ly:set-option 'debug-skylines) \header { tagline=##f } << \new Staff = "A" { g4(_\fermata g'')\fermata \change Staff = "B" g(_\fermata \change Staff = "A" g'')\fermata } \new Staff = "B" { s1 } >>
More concise (or ...) syntax for conditional switch https://codereview.appspot.com/573730044
Issue #1204: fix font-name-add-files regtest The temporary directory might not be empty if some versions of fontconfig add a .uuid file inside it. https://codereview.appspot.com/573730044
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=b9255b50886e5e0de802a26fd486c908b0b55c0f https://codereview.appspot.com/551650043/
On 2020/04/09 19:52:47, c_sorensen wrote: I'm OK to have you push it, but I'd like to hear from those involved in the release whether or not the steps in the CG were followed. Well, I introduced new CG additions to that effect a few weeks ago: https://sourceforge.net/p/testlilyissues/issues/5837/ So, it’s still fairly recent. V. https://codereview.appspot.com/551650043/
This is https://codereview.appspot.com/557640051/, patch set #4. I did make a mistake when I posted my "pushed as" URL.
On 4/9/20, David Kastrup dakas@users.sourceforge.net wrote: dak@lola:/usr/local/tmp/lilypond$ out/bin/lilypond #(rmdir dummyfontdir) Directory not empty I’m at a loss: valentin / lilypond $: out/bin/lilypond input/regression/font-name-add-files.ly GNU LilyPond 2.21.0 Processing input/regression/font-name-add-files.ly' Parsing... Finding the ideal number of pages... Fitting music on 1 page... Drawing systems... Layout output to/tmp/lilypond-5kKSn3'... Converting to font-name-add-files.pdf'......
Reviewers: , Message: This seems trivial enough; may I just push onto staging? Cheers, V. Description: Web: update documentation symlinks, and use https in RewriteRules Please review this at https://codereview.appspot.com/551650043/ Affected files (+4, -4 lines): M Documentation/web/server/lilypond.org.htaccess Index: Documentation/web/server/lilypond.org.htaccess diff --git a/Documentation/web/server/lilypond.org.htaccess b/Documentation/web/server/lilypond.org.htaccess index 480fc3d5a795d21afdeb09e9b4d80860245941f4..5b83bfe5213f3e822e7083802fe9890c08adf36c...
Documentation and regtests needed for external font files
Could you elaborate? I spent hours making sure it worked without side-effects.
Documentation and regtests needed for external font files
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=9a399c21ea6ff5ad270f025b300ba39fdc7df6f2
Regtests cleanup: fix texidoc strings
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=1dd353f70131eabd43a1b6455d6d05b58fb9db79
Is this issue still relevant? As of 2.20 the following setting is no longer working (or have I overlooked a syntax change?): \override Score.MetronomeMark.non-break-align-symbols = #'(paper-column-interface) Besides, Xavier’s two examples now look exactly the same. Couldn’t/shouldn’t we rather make it simply a matter of documenting the current behavior (which, by the way, doesn’t look so ugly to me)?
Documentation and regtests needed for external font files
Hi James, could you check again (using my latest patch set, numbered 4)? make check works correctly here with my latest bugfix. (Plus, the patchy log looks like an unrelated problem.)
bookpart-variable.ly regtest texidoc string not rendered in collated files
Temporarily disable font-export-dir (fixes make test) https://codereview.appspot.com/557640051
Documentation and regtests needed for external font files
Please disregard, my latest attemp breaks regtest compilation. I’ll be back shortly.
Use mkstemp! instead of tmpnam; don’t leave any temporary file behind. https://codereview.appspot.com/557640051
Web: update CG instructions, `attic’ page and THANKS for 2.18
Pushed as http://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=f5f907599ce88d3d610483fa42fa78be12f53d2e
Some nits from Werner https://codereview.appspot.com/557640051
Issue #1204: Document, and add regtest for, external fonts. Add a few details in NR 1.8.3.1 "Fonts explained", and a regtest with base64-embedded minimal OpenType fonts. (I didn’t want to use musical symbols since the whole point is that these glyphs are not to be confused with whatever’s installed on the OS.) The regtest has been tested with all major versions since 2.12, and current master with and without Guile2. https://codereview.appspot.com/557640051
As part of my patch related to Issue 4375, I changed the error message to programming error: Multi measure rest seems misplaced. Which is at least more intelligible than getrods (): I am not spanned! (besides, that function’s no longer named get_rods). Maybe David’s suggestion would be better, though: multimeasure rest size not a multiple of bar size Or for more clarity Multi measure rest’s duration is not a multiple of the current measure length. Thoughts?
As part of my patch related to Issue 4375, I changed the error message to programming error: Multi measure rest seems misplaced. Which is at least more intelligible than getrods (): I am not spanned! (besides, that function’s no longer named get_rods). Maybe David’s suggestion would be better, though: multimeasure rest size not a multiple of bar size Or for more clarity Multi measure rest’s duration is not a multiple of the current measure length. Thoughts?
As part of my patch related to Issue 4375, I changed the error message to programming error: Multi measure rest seems misplaced. Which is at least more intelligible than getrods (): I am not spanned! (besides, that function’s no longer named get_rods). Maybe David’s suggestion would be better, though: multimeasure rest size not a multiple of bar size Or for more clarity Multi measure rest’s duration is not a multiple of the current measure length. Thoughts?
As part of my patch related to Issue 4375, I changed the error message to programming error: Multi measure rest seems misplaced. Which is at least more intelligible than getrods (): I am not spanned! (besides, that function’s no longer named get_rods). Maybe David’s suggestion would be better, though: multimeasure rest size not a multiple of bar size Or for more clarity Multi measure rest’s duration is not a multiple of the current measure length. Thoughts?
\compressFullBarRests should be renamed
Pushed (a bit prematurely, sorry about that) as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?h=staging&id=83045b846acb4aaadf54373941a915c4c45fb522
Here’s my suggestion: By default, every chord entered is printed; this behavior can be modified so that chord names are printed only at the start of lines and when the chord changes. If that’s OK with you guys, I’ll edit the LSR and it’ll appear in the manuals with the next makelsr round and the next unstable release.
Doc: NR - Clarify that default chord settings can be overridden
Here’s my suggestion: By default, every chord entered is printed; this behavior can be modified so that chord names are printed only at the start of lines and when the chord changes. If that’s OK with you guys, I’ll edit the LSR and it’ll appear in the manuals with the next makelsr round and the next unstable release.
Enhancement: simplify accepting a new custom context like an existing context
Closing. See issue 4561.
Actually, you don’t even need \autoChange to reproduce the bug: << \new Staff { c'''16[ c''' c''' \change Staff = "z" c'] } \new Staff = "z" { s4\p } >> Not only is the beam messed up, the Stem is misaligned as well: << \new Staff { c'''8[ \change Staff = "z" c'] } \new Staff = "z" { s4\p } >> This produces a whole lot of errors and warnings: programming error: Grob direction requested while calculation in progress. warning: no viable initial configuration found: may not find good beam slope programming...
Dynamics attached to spacer rests mess up stems with cross-staff kneed beams
Actually, you don’t even need \autoChange to reproduce the bug: << \new Staff { c'''16[ c''' c''' \change Staff = "z" c'] } \new Staff = "z" { s4\p } >> Not only is the beam messed up, the Stem is misaligned as well: << \new Staff { c'''8[ \change Staff = "z" c'] } \new Staff = "z" { s4\p } This produces a whole lot of errors and warnings: programming error: Grob direction requested while calculation in progress. warning: no viable initial configuration found: may not find good beam slope programming...
\compressFullBarRests should be renamed Rename \compressFullBarRests to \compressEmptyMeasures as suggested by Trevor in #4375. Document the new command (and explain its difference with \compressMMRests) by creating a new subsubsec in NR 1.6.3 "Writing parts". Add index entries and links everywhere I can think of, obviously starting with NR 1.2.2.3 "Full measure rests". Add convert rule and update syntax through the doc. Clarify the (in)famous progerror "Multi_measure_rest::get_rods (): I am not...
Web: update and document documentation symlinks
Thanks! Pushed onto staging as http://git.savannah.gnu.org/cgit/lilypond.git/commit/?h=staging&id=140a50e2ae2a3db4a41fab15816f00cc1f114e2b
Also update CG release guidelines https://codereview.appspot.com/559640043
Documentation: elaborate NR `custom percussion’ section
Thanks for reminding me, James. Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=bc46cc1fef7eecd0a64ac60223d40e98d79c9958; please verify!
Documentation: elaborate NR `custom percussion’ section
Documentation: no \layout in markup-nested scores
Thanks! Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=6ecee87252c0134dc3428043050d7a3d0dc6fdd3
Use new syntax consistently throughout docs and examples
Documentation: no \layout in markup-nested scores
Crash with malformed tremolo code
This crash appears to have been fixed for at least five years; I move to close this issue.
Hi David, could the regtest diff only be due to a different rounded value? Also, I noticed that the same code that you fixed is also found in Stem_tremolo::calc_y_offset (but I haven’t found a way to trigger the crash with that), are we sure that it wouldn’t need to be rewritten into add_point as well? The same failed assertion (or something very similar) is found in [#3374] and possibly in [#5281].
Temporary staff not ending
See also [#5499].
Temp. Staff not stopped when its length’s less than a fourth note
Enhancement: inequal MIDI quantization of equal durations (swing, rubato)
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=464cf0d8111976c63fe778f358ddbe28bce532a8 Please verify!
Enhancement: beamed acciaccaturas should be printed with a slash
Possibly superseeded by [#5493].
Enhancement: inequal MIDI quantization of equal durations (swing, rubato)
I’ve turned Johannes Rohrer’s excellent contribution into a patch for possible upstream distribution, with some documentation: http://codereview.appspot.com/572520044 Peter’s original rubato idea is equally interesting, but much harder to define let alone implement. I suggest we keep it simple and consider this issue fixed with regard to swing patterns and automated inequal rhythms. (Which still leaves [#3003] to grapple with -- but that’s a separate matter.)
Allow scripts to be defined either as glyphs or stencils.
Well, it’s actually worse than that: it appears that this patch actually isn’t worth pursuing. I’m closing it down.
undefined operation (GCC warning) in page-turn-page-breaking.cc
C++ cleanup : get rid of some compilation warnings
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=e94db23e6c620396aafba5dc2b30a4d2e5ef70e0 Please verify!
-o description in man page should offer FILE or FOLDER as in Usage manual
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=3aeb41c27fa9db60eb6faa7c0c8532614697d06c Please verify!
Use "simple strings" rather than #"hash-prefixed Scheme strings"
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=ed86e71eb0f17e93036142938d8c490a3e2fcbea Please verify!
Enhancement: NoteNames context should handle any note names language
Documented and pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=965a6070969789ec4cf79c7c8f0f27770fea9d70 Please verify!
Add HackLily online editor
Pushed as https://git.savannah.gnu.org/cgit/lilypond.git/commit/?id=cb1963c46a557fdab022a867403198b1a8332077
C++ cleanup : get rid of some compilation warnings
Oh, I think we can safely put it on countdown. These are minor, fairly uncontroversial changes (apart from the new warning for --relocate, which Werner hasn’t objected against).