User Activity

  • Created a blog post on IPMI Management Utilities

    ipmiutil-3.0.7 is released

  • Committed [e8c01c]

    changes for ipmiutil-3.0.7

  • Committed [r357]

    updates for ipmiutil-3.0.7

  • Posted a comment on ticket #29 on IPMI Management Utilities

    I cannot think of any reason why you would EVER need lanplus when booted to WinPE. On Mon, Aug 14, 2017 at 3:23 PM, Craig Jackson craigmjackson@users.sf.net wrote: OK thanks, this does help. I will do a dependecy walker on those DLLs to narrow this down. Or, as a last resort, I can make a wrapper that calls the lanplus version if a lanplus call is made. [support-requests:#29] ipmiutil 3.0.6 x64 WinPE run issue Status: open Group: ipmiutil-3.0.x Created: Fri Aug 11, 2017 05:50 AM UTC by Craig Jackson...

  • Posted a comment on ticket #29 on IPMI Management Utilities

    From the ipmiutil UserGuide, section 5.2.7, it said: "If you are using ipmiutil for a bootable WinPE environment, and do not need Serial-Over-LAN functionality, the buildwin2.cmd will build the Windows EXE files without using the openssl libraries, to simplify the process. The openssl libraries are required for the IPMI LAN 2.0 crypto functions that Serial-Over-LAN requires." I'll update this for buildmin.cmd, and make this part of a 5.2.8 section for WinPE.

  • Posted a comment on ticket #29 on IPMI Management Utilities

    Known dependencies for the default Windows build: libeay32.dll, ssleay32.dll, iphlpapi.dll, and some portion of vc6redist. Here are some possibilities: The openssl DLLs may depend on some other Windows DLLs that we didn't know about. The iphlpapi.dll needs some other Windows DLLs that WinPE does not have. It needs something from vc6redist that WinPE does not have. The most likely of these is some openssl DLL dependencies. However, the approach of using a minimal build for boot environments like WinPE...

  • Posted a comment on ticket #29 on IPMI Management Utilities

    There are a few things to try for the WinPE runtime issue. First, does the pre-built one in the 3.0.6 zip run under WinPE (with the libeay32.dll ssleay32.dll in the same directory)? It may also need iphlpapi.dll from Windows\system32. Also there is a minimal build script which builds without openssl (so no IPMI LAN/SOL functions), intended for WinPE and boot environments (was buildwin2.cmd, now will be buildmin.cmd). This leverages the attached util/ipmiutil2.mak files. So you could try building...

  • Posted a comment on ticket #29 on IPMI Management Utilities

    The

View All

Personal Data

Username:
arcress
Joined:
2002-08-28 16:09:42

Projects

Skills

  • No skills entered.

Personal Tools