TekSIPKaplanSoft
|
websocketsPython Software Foundation
|
|||||
Related Products
|
||||||
About
TekSIP is a SIP Registrar and SIP Proxy for Windows. TekSIP supports UDP, TCP, TLS and WebSocket (IPv4 & IPv6) transports. TLS and Secure WebSocket are supported in only commercial editions. TekSIP is tested on Microsoft Windows Vista, Windows 7/8/10/11 and Windows 2008-2022 server. TekSIP can be deployed as a signaling server for WebRTC based SIP phones.
TekSIP complies with RFC 3261, RFC 3263, RFC 3311, RFC 3581 and RFC 3891. It supports NAT traversal and ENUM. Please see technical details about NAT traversal in Readme. You can select IP address to be listened and alternative SIP endpoints for outgoing calls. You can also log session details into a log file and monitor active registrations and sessions in real-time. You can monitor number of active registrations and sessions using Windows Performance Monitor (Perfmon.exe). TekSIP can redirect calls to alternate endpoint when called endpoint is unavailable (Off-line, busy...). Active SIP session can be terminated via GUI.
|
About
An implementation of the WebSocket Protocol (RFC 6455 & 7692). websockets is a library for building WebSocket servers and clients in Python with a focus on correctness, simplicity, robustness, and performance. Built on top of asyncio, Python’s standard asynchronous I/O framework, it provides an elegant coroutine-based API. websockets is heavily tested for compliance with RFC 6455. Continuous integration fails under 100% branch coverage. websockets is built for production. For example, it was the only library to handle backpressure correctly before the issue became widely known in the Python community. Memory usage is optimized and configurable. A C extension accelerates expensive operations. It’s pre-compiled for Linux, macOS, and Windows and packaged in the wheel format for each system and Python version. websockets takes care of everything under the hood so you can focus on your application!
|
|||||
Platforms Supported
Windows
Supported
Mac
Not Supported
Linux
Not Supported
Cloud
Not Supported
On-Premises
Supported
iPhone
Not Supported
iPad
Not Supported
Android
Not Supported
Chromebook
Not Supported
|
Platforms Supported
Windows
Supported
Mac
Supported
Linux
Supported
Cloud
Not Supported
On-Premises
Not Supported
iPhone
Not Supported
iPad
Not Supported
Android
Not Supported
Chromebook
Not Supported
|
|||||
Audience
Enterprise, Service Providers, Utility Companies
|
Audience
Teams, individuals and developers requiring a solution for building WebSocket servers and clients in Python
|
|||||
Support
Phone Support
Supported
24/7 Live Support
Supported
Online
Supported
|
Support
Phone Support
Not Supported
24/7 Live Support
Not Supported
Online
Supported
|
|||||
API
Offers API
Supported
|
API
Offers API
Supported
|
|||||
Screenshots and Videos |
Screenshots and Videos |
|||||
Pricing
$239
Freeware version allows maximum 3 SIP endpoints registration and 3 simultaneous SIP sessions. Enterprise edition allows upto 100 simultaneous registration and SIP sessions. Following features are not supported in free edition;
Enterprise * SDP Manipulation * TLS Transport * SMPP Gateway SP * Enterprise features * External Authenticator * SRTP -> RTP interworking * WebRTC Media Gateway * Unlimited number of simultaneous SIP registrations and sessions * Route incoming calls to registered extensions * IPv6 support * RADIUS AAA
Free Version
Supported
Free Trial
Supported
|
Pricing
Free
Free Version
Supported
Free Trial
Not Supported
|
|||||
Reviews/
|
Reviews/
|
|||||
Training
Documentation
Supported
Webinars
Not Supported
Live Online
Supported
In Person
Not Supported
|
Training
Documentation
Supported
Webinars
Supported
Live Online
Not Supported
In Person
Not Supported
|
|||||
Company InformationKaplanSoft
Founded: 2011
Turkey
www.kaplansoft.com
|
Company InformationPython Software Foundation
United States
pypi.org/project/websockets/
|
|||||
Alternatives |
Alternatives |
|||||
|
|
||||||
|
|
||||||
|
|
|
|||||
Categories |
Categories |
|||||
Telephony Features
Auto-Dialer
Not Supported
Call Center Management
Not Supported
Call Monitoring
Supported
Contact Management
Not Supported
Inbound Reporting
Not Supported
IVR / Voice Recognition
Not Supported
Outbound Reporting
Not Supported
Predictive Dialer
Not Supported
Telemarketing Management
Not Supported
Voice & Data Integration
Supported
VoIP
Supported
|
||||||
Integrations
Azure Web PubSub
Not Supported
Bun
Not Supported
Hoppscotch
Not Supported
Parasoft
Not Supported
Python
Not Supported
Runware
Not Supported
Specmatic
Not Supported
TekRADIUS
Supported
xFans
Not Supported
|
Integrations
Azure Web PubSub
Supported
Bun
Supported
Hoppscotch
Supported
Parasoft
Supported
Python
Supported
Runware
Supported
Specmatic
Supported
TekRADIUS
Not Supported
xFans
Supported
|
|||||
|
|
|