Menu

#5179 pam_unix(webmin:auth)

1.890
closed-invalid
nobody
None
5
2018-09-08
2018-08-15
M.T.R
No

Hi Jamie,
i know this is an old issue,
but i would be happy to find a workaround to get rid of this:

It happens everytime booting the server:
pam_unix(webmin:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost= user=root

How could i modify the webmin start parameters, to make this not happen everytime?

Thanks for advice

cheers mike

Discussion

  • Matt Wilcox

    Matt Wilcox - 2018-09-04

    I'm getting this and Webmin will not start after a reboot of the server.

    service webmin restart

    Job for webmin.service failed because the control process exited with error code. See "systemctl status webmin.service" and "journalctl -xe" for details.

    systemctl status webmin.service

    webmin.service - LSB: web-based administration interface for Unix systems
    Loaded: loaded (/etc/init.d/webmin; bad; vendor preset: enabled)
    Active: failed (Result: exit-code) since Tue 2018-09-04 14:31:42 BST; 1min 7s ago
    Docs: man:systemd-sysv-generator(8)
    Process: 3474 ExecStart=/etc/init.d/webmin start (code=exited, status=2)

    Sep 04 14:31:40 server14.REDACTED systemd[1]: Starting LSB: web-based administration interface for Unix systems...
    Sep 04 14:31:40 server14.REDACTED perl[3475]: pam_unix(webmin:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost= user=root
    Sep 04 14:31:42 server14.REDACTED systemd[1]: webmin.service: Control process exited, code=exited status=2
    Sep 04 14:31:42 server14.REDACTED systemd[1]: Failed to start LSB: web-based administration interface for Unix systems.
    Sep 04 14:31:42 server14.REDACTED systemd[1]: webmin.service: Unit entered failed state.
    Sep 04 14:31:42 server14.REDACTED systemd[1]: webmin.service: Failed with result 'exit-code'.

     
  • Matt Wilcox

    Matt Wilcox - 2018-09-04

    This error turned out to be a result of a configuration problem when an attempt to get SSL onto a server had failed; leaving webmin with config files expecting an SSL certificate, but no SSL certificate being available.

     
  • Jamie Cameron

    Jamie Cameron - 2018-09-05
    • status: open --> closed-invalid
     
  • Jamie Cameron

    Jamie Cameron - 2018-09-05

    That would explain it!

     
  • M.T.R

    M.T.R - 2018-09-05

    hi jamie,

    don't really understand your answer,
    cause the other user's statement has nothing to do with my reported problem:

    **It happens everytime booting the server:
    pam_unix(webmin:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost= user=root

    How could i modify the webmin start parameters, to make this not happen everytime?

    Thanks for assistance

    cheers mike

     
  • Jamie Cameron

    Jamie Cameron - 2018-09-08

    MTR - that happens because on startup Webmin checks if the PAM module is really working and properly configured, by doing a test authentication. You can just ignore that log entry..

     

Log in to post a comment.