Viewing zipped JPEG images

H. H.
<< < 1 2 (Page 2 of 2)
  • Peter Hoeg

    Peter Hoeg - 2012-06-07

    All, nicorac's patched binaries do the trick.

  • Jaroslav Mazurak

    Is official distribution applied by the patch? Which version?

  • handbagsusd

    handbagsusd - 2012-06-18

    You could use an image viewer

  • Claudio Nicora

    Claudio Nicora - 2012-09-13

    Since the link has died, I uplodaded my patched version here on sourceforge:

  • Scream

    Scream - 2012-09-15

    Can you provide a patched 9.29 version?

  • Gabriel Magana-Gonzalez

    Igor does not make sources for alpha versions available. :-(

  • Forcen

    Forcen - 2013-06-18

    Is there really no ticket for this?

  • deepak

    deepak - 2013-06-20

    Hi Team,
    we getting problem in our organization while opening of any pdf or jpeg file directly from 7-zip.if we extract the file then its working properly.We are getting "File can not be found"error.Also we have seclore desktop client application installed in all systems.
    Please check this issue , we are getting error since long time.
    Awaiting for reply.

  • nRoof

    nRoof - 2013-06-20

    7-zip deletes temorary files when the opener process gets closed.

    But as far as I know other archivers like PeaZip or WinRAR will delete temporary files only on exit from the archiver. So they don't have that problem at all.

    Is that possible to implement the same in 7-zip?

  • Andreas Hoppe

    Andreas Hoppe - 2013-10-01

    Hello Igor,

    I have a really similar problem on viewing multiple PDF-documents (some are 'big'), archived in a ZIP-File, direct in 7zfm.

    Without closing the first opened PDF-doc in AdobeReader, mostly the next PDFs won't be displayed with Error "File can not be found". Sometimes it will work, but frequently not.

    I made some investigations with process-explorer...
    The temporarily extraction of the PDF-file to the %temp% folder was, in case of the error, not (!) succesfull created by 7zip, and so missing for the viewer process (here it is Adobe Reader with the argument to the path of the pdf file). The missing file will be not created untill a next try to open/view it in 7zfm.

    So it is perhaps 'just' a timing issue in 7-zip for me that Claudio Nicora (nicorac) already solved on 2012-02-06 here in this thread.

    Could you please investigate the issue and resolve it like Claudio in the next version of 7-zip?

    Using: 7-zip 9.25_64bit on Win7-SP1 (64) and AdobeReader 10.1.7

    By the way, after closing the reader and 7zfm, all my temporarily 7z-Folders within the files in %temp% are still there and haven't been deleted.

  • Peter Wanjala

    Peter Wanjala - 2014-03-12

    Hi All, i am facing the same challenge whereby i cannot open .jpg/.jpeg and .tif files which are in compressed format using 7-zip. Has there been any solution to this bug?

  • Sandwich

    Sandwich - 2014-04-13

    I'd like to add my voice here... I download zip files of website add-ons, which I'd then like to drag and drop into WinSCP to upload them. However, since 7zip deletes things too quickly, there's no files left for WinSCP to upload.

    I'd also like to point out that these workarounds of adding a second or two of delay won't work in this instance... it can take minutes (occasionally even hours, though that's rare) to upload the contents of an archive if there's lots of tiny files and only one connection.

    Far as I can tell, the only real solution is to leave the temporary files alone altogether... as long as they're being extracted into the system's temp folder, let the system decide when and how to delete them.

  • ducquoc

    ducquoc - 2014-12-04

    This is a known issue of 7-zip. Fortunately there is a workaround:

    Work-around: use another photo viewer as default (instead of Windows Photo Viewer). Make sure the format of pictures are associated with your new photo viewer before opening them in 7-zip.
    (for example: you may associate ".png" always open in Picasa, or ".jpeg" always open in FastStone, or ".gif" always open in XnView)

    hope this helps,

  • Yakumo

    Yakumo - 2015-02-15

    9.38 x64 beta on win8.1

    7zip is a truly excellent product, and I am exceedingly grateful for it, but it is frustrating that nearly 6 years on and this is still a problem :-(

    Last edit: Yakumo 2015-02-15
  • German

    German - 2015-08-28

    I have this problem. I've been looking and the problem is not solved yet. I don't know why some computers have this problem and others not.

    I think that if this is not solved I will use PeaZip. There are good references.

<< < 1 2 (Page 2 of 2)

Log in to post a comment.