unable to login to web interface using default admin/admin credentials

Help
fenixtx40
2013-08-09
2014-12-06
  • fenixtx40

    fenixtx40 - 2013-08-09

    Hello,

    I've bump into a really weird situation.

    This is a fresh installation of both Virtual Box (4.2) and phpvirtualbox.

    I've tried to login using the default credentials (admin/admin) and so far i'm unable to do so.

    I even tried to use the recovery.php procedure (which was sucessful according to the script) and i'm still unable to login using the default credentials.

    As a workaround i disabled the authentication in config.php using $NoAuth = true and this allowed me to login into the tool (which let me manage my VirtualBox setup).

    Please help me on this one :)

    PHP 5.3.3 / nginx 1.0.15 / phpVirtualBox 4.2-6 / VirtualBox 4.2.16_86992_el6 / CentOS 6.4 x86_64

     
    Last edit: fenixtx40 2013-08-09
  • Ian Moore

    Ian Moore - 2013-08-09

    Hello,

    That is odd. Can you post the output of:

    VBoxManage getextradata global enumerate | grep phpvb

    please?

     
  • netcrew

    netcrew - 2013-08-09

    Hi lan Moore,

    thanks for u helping!

    So, this is what gives me your command:
    (Nothin...)

    So i start the Service:
    vbox@server:~$ su vbox -c "vboxwebsrv"
    Passwort:
    Oracle VM VirtualBox web service Version 4.2.16
    (C) 2007-2013 Oracle Corporation
    All rights reserved.
    VirtualBox web service 4.2.16 r86992 linux.amd64 (Jul 4 2013 14:41:02) release log
    00:00:00.000131 main Log opened 2013-08-09T18:35:24.201348000Z
    00:00:00.000138 main OS Product: Linux
    00:00:00.000140 main OS Release: 2.6.32-5-amd64
    00:00:00.000141 main OS Version: #1 SMP Fri May 10 08:43:19 UTC 2013
    00:00:00.000163 main DMI Product Name: MS-7596
    00:00:00.000172 main DMI Product Version: 1.0
    00:00:00.000235 main Host RAM: 15830MB total, 15221MB available
    00:00:00.000240 main Executable: /usr/lib/virtualbox/vboxwebsrv
    00:00:00.000241 main Process ID: 20595
    00:00:00.000242 main Package type: LINUX_64BITS_DEBIAN_6_0
    00:00:00.005786 SQPmp Socket connection successful: host = default (localhost), port = 18083, master socket = 8

    vbox@server:~$ VBoxManage getextradata global enumerate | grep phpvb
    vbox@server:~$ ( nothing ... )

    vbox@server:~$ VBoxManage getextradata global enumerate
    vbox@server:~$ ( nothing ... )

    vbox@server:~$ VBoxManage getextradata global
    Oracle VM VirtualBox Command Line Management Interface Version 4.2.16
    (C) 2005-2013 Oracle Corporation
    All rights reserved.

    Usage:

    VBoxManage getextradata global|<uuid>|<name>
    <key>|enumerate

    Syntax error: Incorrect number of parameters

    vbox@server:~$ vboxmanage list vms
    vbox@server:~$ ( nothing ... )

    As root its the same thing...
    What can i do!? :-(

    Maybe help this by support me, this is the HowTo, and i install this stepbystep
    http://www.laub-home.de/wiki/Virtualbox_mit_Webinterface_unter_Debian_Linux

     
    Last edit: netcrew 2013-08-09
  • fenixtx40

    fenixtx40 - 2013-08-10

    Hi Ian,

    I figured it out on my own. Even though the interface stated "invalid username/password" i traced it back to the php engine not being able to write to /var/lib/php/session (the session folder did not exist). Just created the folder and gave it the right permissions. (had to add some variable-dumping code into your Builtin.php to figure out the authentication part was working fine - the admin entries were created with the setextradata property of VBoxManage just fine -)

    Also, had to add VBOXWEB_AUTH_LIBRARY=null into /etc/default/virtualbox (had tried the "VBoxManage setproperty vboxwebsrvauthlibrary null" command a couple of times, and looks like vboxwebsrv ignored it after rebooting)

    So far the setup is working as expected.

    My final words: You are THE MAN, this frontend has really helped me managing my VMs while away from home.

    Please close this forum entry as resolved.

    (P.S. Please bare with my english, i'm a non-native speaker of the language.)

     
  • GorillaD

    GorillaD - 2014-12-06

    I just wanted to chime in that after beating my head against the wall for over an hour this turned out to be be one of my problems too. I'm running CentOS 7 with nginx and phpvirtualbox-4.3-1 and ran into the same issue where the default login (admin/admin) did not work and still didn't work after using the recovery.php file tool. I found that after creating the /var/lib/php/session directory and setting permissions to 777 (probably overkill but it's a limited access system) that I could log in. Thanks fenixtx40 for posting your solution and of course, thanks Ian Moore for phpvirtualbox!!!!!!

    --Andrew

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks