"unable to connect" to phpvirtualbox - I'm just stuck :-(

Help
Rob Whight
2014-05-05
2014-05-11
  • Rob Whight

    Rob Whight - 2014-05-05

    Folks,

    I'm struggling to set up a Linux home server following the instructions
    on www.linuxhomeserverguide.com. I know that some of the instructions
    are out of date by a few years and have been working my way through
    updating and finding appropriate downloads as I go. (Yes - I'm a
    complete noob with Linux !)

    I've installed Ubuntu Server 14.04, can access it fine from my Windows
    pc via Putty and have Webmin running as well. I've installed apache2 and
    believe I have installed phpvirtualbox as well.

    I can connect to the standard apache2 page from my windows pc which
    shows that this is working fine by typing 192.168.1.60 (Address of the
    server).

    I can't seem to get to the log in page for phpvirtualbox though. Using
    Putty, I can enter:
    sudo /etc/init.d/vboxweb-service status
    and get a response of
    Checking for VBox Web Service ...running

    Yet, when trying to access the login page from the windows pc (using
    firefox), I have tried all of the following (which gives away some
    frustration and the noob-ness), all with the same result:
    127.0.0.1
    127.0.0.1:18083
    192.168.1.60:18083
    192.168.1.60/phpvirtualbox
    192.168.1.60/vb

    All come up with "Unable to connect - Firefox can't establish a link to
    the server at ....." (what I would describe as firefox telling me I have
    pointed it at something that doesn't exist)

    Any clues would be much appreciated as this has now taken about two days
    of my life :-(

    If you need any further info, please let me know what and how to get it.

    Many thanks and your patience with a muppet much appreciated.

    Rob

     
  • Steve

    Steve - 2014-05-06

    Rob,

    Can you check the contents of /var/log/vbox.log? (i.e. cat /var/log/vbox.log)

    I suspect you'll find the last line looks something like:

    SOAP FAULT: [SOAP-ENV:Server]

    Which, if true, will lead us to this dead end:
    https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1254071

    Shame, because heretofore PHPVB has been a fantastic bit of software.

    If I find a resolution I'll be sure to let you know...

     
  • Steve

    Steve - 2014-05-06

    Rob,

    If you're still having trouble, and it is the SOAP error as suggested in my previous post, then I've some good news having experimented a little further this morning.

    Firstly, you'll need to use the IP V6 version of localhost in /etc/default/virtualbox:
    VBOXWEB_HOST=::

    Yep - just two colons as opposed to "localhost" or 127.0.0.1 or whatever. The configuration of PHPVB can remain as is...

    Having just re-read your initial post, I may have run away with things a little - are you saying that you can't connect to the initial page of phpvb? If so, that'll depend where you've actually installed it! Assuming pointing your browser at http://192.168.1.60 gives a valid response (i.e. Apache is up as you suggest), and assuming you've unzipped the phpvb source to /var/www/phpvb, then you should be after http://192.168.1.60/phpvb/

    Also, bizarrely found that Chrome doesn't seem to work with phpvb any more - not sure about Firefox - but I've been able to get it working with IE11 - which is odd!

    Hope this helps,

    Steve

     
  • Nico

    Nico - 2014-05-10

    HI Steve,

    I am brand new to phpvb and a bit lost with this SOAP issue.

    I downloaded the latest Ubuntu Server, Apache2, PHP and obviously the phpvb files from here, earlier today. Now this "SQPmp #### SOAP FAULT: [SOAP-ENV:Server]" seems to be my issue too.

    The thing is that when I open the /etc/default/virtualbox file there is NO mention of VBOXWEB_HOST= at all.

    Am I misunderstanding your suggestion?

    Please explain exactly where and what to do with VBOXWEB_HOST=::

    Regards,
    Nico

     
  • Nico

    Nico - 2014-05-11

    Not to worry gentlemen. all sorted!

    Nico

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks