Error setting up VDE networking

  • Robin McCorkell

    Robin McCorkell - 2014-06-05

    I am trying to get VDE networking set up for some virtual machines. In the VirtualBox GUI, I can assign a Generic Driver interface to a machine with the VDE driver, then apply the parameter 'network=...' to define the VDE switch (as per Oracle documentation). This works fine. However, attempting to do the same through phpVirtualBox does not work.

    I noticed that phpVirtualBox has the '$enableVDE' configuration setting, so I enabled that in an attempt to get this working, but I get 'Attribute does not exist' errors any time I click on a virtual machine. This is the error that has been reported many times, such as . The difference in this case is that I actually want VDE to work!

    I am running VirtualBox 4.3.12 on Ubuntu 12.04, downloaded from the Oracle website, along with the extension pack. Likewise, phpVirtualBox 4.3-1 is in use

    Last edit: Robin McCorkell 2014-06-05
  • Robin McCorkell

    Robin McCorkell - 2014-06-05

    Actually, after some permission changing, I got the first method working over phpVirtualBox (Generic driver + VDE). Still not sure what the $enableVDE option is for though.

  • Qho Li

    Qho Li - 2014-06-24

    Have same issue here. I had compiled with "--enable-vde", and installed it. All is well for using VDE with setup "Generic Drive", but set the "true" for the option "$enableVDE" in config.php of phpVirtualBox that is not work and prompt the same error "Attribute does not exist". Is the VDE function not complete on phpVirtualBox? Or we missed any setting?
    Thanks a lot.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks