Unable to login to phpvirtualbox running virtualbox4.3.6

Help
skynetky
2014-01-09
2015-05-12
  • skynetky

    skynetky - 2014-01-09

    When trying to login to virtual box I get the following error OS Ubuntu 12.04LTS

    Exception Object
    (
    [message:protected] => Error logging in to vboxwebsrv.
    [string:Exception:private] =>
    [code:protected] => 64
    [file:protected] => /var/www/vb/lib/ajax.php
    [line:protected] => 128
    [trace:Exception:private] => Array
    (
    )

    [previous:Exception:private] =>
    
     
  • Scorp

    Scorp - 2014-01-09

    The same error on OS Ubuntu Server 12.04 LTS 64 Bit

     
    Last edit: Scorp 2014-01-09
  • Benjamin Lea

    Benjamin Lea - 2014-04-13

    EDIT: So I thought the below fixed the issue, turns out it didn't. I'm using phpVirtualBox 4.3-1 with VirtualBox 4.3.10 on Ubuntu 12.04.

    Hey guys, I came here with the same issue but worked out the problem.

    I'm running VirtualBox version 4.3.10, but downloaded phpVirtualBox version 4.2.8. According to the "all files" page, the versions have to match up (a.k.a. get phpVirtualBox version 4.3 for VirtualBox version 4.3).

    I accidentally downloaded version 4.2 because that's the download file linked on the project home page. You can download version 4.3 (or whichever version you require) from the all files page here: https://sourceforge.net/projects/phpvirtualbox/files/

     
    Last edit: Benjamin Lea 2014-04-13
  • Marone Moura de Moraes

    Hi folks!

    I "resolved" this problem running this command:

    VBoxManage setproperty websrvauthlibrary null

    But the same disable the authentication and you need edit the config.php for this running well.

    // Disable authentication

    var $noAuth = true;

     
    Last edit: Marone Moura de Moraes 2015-05-12

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks