#64 Options>Audio Devices... chooser does not set audio device

Mac (4)

I am running OSW in Mac OS X 10.3.9 on a G4 Quicksilver with a
M-Audio Delta 44 audio card. On startup, OSW defaults to /audio/3
which is the Build-in Audio device. The Audio Devices chooser does
not display this state, but comes up blank. Attempts to use the
chooser to select another audio device fail, with OSW still using
Build-in and the chooser coming up blank. This problem was also
present in the last version I ran, 1.2.4. I would have tried to start it
with the appropriate command line argument to choose an audio
device, but there is no documentation on doing this with a packaged
OS X app.

Will O'Donovan

Here are the troubleshooting details:

OSW Startup Output:

OSW - Open Sound World
Version 1.2.7
. . .
Hello Macintosh User:
Detected 1 Midi Input Drivers:
Detected 1 Midi Output Drivers:
/coreaudio: Detecting CoreAudio drivers
/coreaudio: Build-in Audio
/audio/3: 2 input channels
/audio/3: 2 output channels
/coreaudio: Delta 44
/audio/2: 6 input channels
/audio/2: 4 output channels
/coreaudio: Soundflower (16ch)
/audio/1: 16 input channels
/audio/1: 16 output channels
/coreaudio: Soundflower (2ch)
/audio/0: 2 input channels
/audio/0: 2 output channels

The Options>Dump Profile output:

/implicit_time_manager 0.029103
/test/out0 0.209651
/audio/3 0.009574
/dock/input 4.1e-05
/dock/tm 0.023962

Hardware Overview:

Machine Model: Power Mac G4
CPU Type: PowerPC G4 (2.1)
Number Of CPUs: 1
CPU Speed: 800 MHz
L2 Cache (per CPU): 256 KB
Memory: 1.12 GB
Bus Speed: 133 MHz
Boot ROM Version: 4.3.3f2

System Software Overview:

System Version: Mac OS X 10.3.9 (7W98)
Kernel Version: Darwin 7.9.0
Boot Volume: MacOS X 1

M-Audio Delta 44 sound card driver:

Driver Version 2.0.2
Panel Version 1.3.2
Build Number 243


  • Will O'Donovan

    Will O'Donovan - 2005-06-26
    • priority: 5 --> 7
  • Will O'Donovan

    Will O'Donovan - 2005-06-26

    Logged In: YES

    I found the reference to the command line and tried it.

    /usr/local/bin/osw -l
    resulted in
    Available Audio Drivers:

    /usr/local/bin/osw -dr 2
    /usr/local/bin/ows -dr "/audio/2"
    still resulted in /audio/3 (built-in) being chosen.

  • Amar Chaudhary

    Amar Chaudhary - 2005-06-26
    • assigned_to: nobody --> peoplestank
  • Amar Chaudhary

    Amar Chaudhary - 2005-06-26

    Logged In: YES

    I am curious what the "Soundflower" entries represent?

  • Amar Chaudhary

    Amar Chaudhary - 2005-08-07

    Logged In: YES

    Please try the following: create a new transform
    "AudioOutput 3 4", which routes output to OSW channels 3 & 4
    rather than the default 1&2. I am guessing these channels
    will be sent to the Delta 44.

    This appears to work with my FireWire 410 (similar to the
    Delta 44).


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks