Hello,
I have installed opensaf 5.0.0 without the PLMS fine for node HA purpose and it's works fine. Now I would like to use opensaf PLMS with the openHPI.
My configure script is -
./configure CPPFLAGS=-DRUNASROOT OSAF_HARDEN_FLAGS="-fstack-protector-all -D_FORTIFY_SOURCE=2" HPI_LIBS="-L/usr/local/lib -lopenhpimarshal -lopenhpiutils -lopenhpi" --enable-hpi --with-openhpi --with-hpi-interface=B03 --enable-tipc=yes --enable-imm-pbe=yes --enable-ais-plm --enable-ais-smf --enable-ais-msg --enable-ais-lck --enable-ais-evt --enable-ais-ckpt --enable-ntf-imcn
Issues found dueing opensaf start up is -following error message is seen -
" ER dlopen() to load libplms_hpi.so failed with error /usr/lib64/opensaf/libplms_hpi.so.0: undefined symbol: plms_plmc_error_cbk"
during the .so loading. Is this issue seen before or some configuration issue from my end. As per my understadning this is due to make file issue.
Temporarily this issue, i could fix by copying the following three methods )with method name changing) from opensaf-5.0.0/osaf/services/saf/plmsv/plms/plms_plmc.c to
opensaf-5.0.0/osaf/services/saf/plmsv/plms/hpi_intf/plms_hsm.c
void plms_os_information_free(PLMS_PLMC_EE_OS_INFO os_info)
static SaUint32T plms_os_information_parse(SaInt8T os_info,
PLMS_PLMC_EE_OS_INFO evt_os_info)
int32_t plms_plmc_error_callbk(plmc_lib_error msg)
int32_t plms_plmc_connect_callbk(SaInt8T ee_id,SaInt8T msg)
int32_t plms_plmc_udp_callbk(udp_msg *msg)
Could you please check the make file for the opensaf-5.0.0/osaf/services/saf/plmsv/plms/hpi_intf/ where dependency is there outside of the folder also.
Regards,
Subrata
Which distro are you using? I have seen this problem on Fedora 23. However, we run it successfully on OpenSUSE 13.1.
I am using RHEL kernel version 3.10.0-327.22.2.el7.x86_64
Try the attached patch instead of yours, and rerun "configure". If you are building just from the released tar file instead of from source control, you will need to modify Makefile.in in the same directory as this patch, too.
Last edit: Alex Jones 2016-09-07
This works in 5.18.04 with CentOS 7.