dot could not display the data (1)

Help
mgalle
2007-09-07
2013-04-17
  • mgalle

    mgalle - 2007-09-07

    After having the same problem as manuel06 I succeful installed kprof.
    Now I'm getting a similar messages as ergeorge: when I open a executable (or directly the file containing the result generate by gprof) I get the message "dot could not display the data (1)".
    The columns of Function/Method and count are filled correctly, but the rest (the interesting part!) are all filled with 0.00. This applies for "[Flat|Hierarchical|Object] Profile". "[Graph|Method] View" are complety blank
    Any ideas? Maybe a parameter for gprof?

    Thanks,

     
    • mgalle

      mgalle - 2007-09-07

      Upss.. the "all 0" problem was my fault. The programm just runs too fast :D
      There remains the fact that there are no graphics.

       
    • lei bobby

      lei bobby - 2008-01-17

      yes, i get the same error.
      Is here anyboddy reply it?

       
      • mgalle

        mgalle - 2008-01-22

        I don't remember, but it was something stupid.
        Check if you have dot installed or if it's in the right path.

        greets,

         
    • jonne

      jonne - 2008-01-27

      I have the same error with (2), which I debugged a little further to obtain a more clear message.
      This is what you can try:
      - Run kprof like normal, you now see your error message "could not display (1)".
      - Without clicking on the error message, in another shell,
        look in the directory /tmp/Kprof_aqIsazzE/ (your name is a little different of course).
      - Is there a file named graphViz_temp over there?
      - If no, ...
      - If yes, no try the following command:
        dot /tmp/Kprof_aqIsazzE/graphViz_temp -Timap

      Probably the last command fails and hopefully for you shows a clear message, which indicates how to fix it?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks