Eric George - 2002-12-17

Ok, if I try to run kprof with a command line such as:
kprof -f exe_name

I get the following error box popping up:
title bar: "Exited with Error(s) - KProf"
message: "dot could not display the data (1)."

When I click <ok> , the KDE crash handler pops up, says the program exited with a signal 11.  The backtrace tab gives this:
"[New Thread 8192 (LWP 6807)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x411c5c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x408da1e5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x406a1dec in KRecentFilesAction::saveEntries(KConfig*, QString) ()
   from /usr/lib/libkdeui.so.4
#6  0x08070243 in KProfTopLevel::queryExit() ()
#7  0x406f0109 in KMainWindow::shuttingDown() () from /usr/lib/libkdeui.so.4
#8  0x406f0a88 in KMainWindow::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkdeui.so.4
#9  0x08070510 in KProfTopLevel::qt_invoke(int, QUObject*) ()
#10 0x40c8ad6b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#11 0x40c8ac57 in QObject::activate_signal(int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#12 0x4087ba3e in KApplication::shutDown() () from /usr/lib/libkdecore.so.4
#13 0x4087bc33 in KApplication::qt_emit(int, QUObject*) ()
   from /usr/lib/libkdecore.so.4
#14 0x40c8ad28 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#15 0x40c8ac57 in QObject::activate_signal(int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#16 0x40f4a96c in QApplication::aboutToQuit() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#17 0x40c382bd in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#18 0x40de58c1 in QDialog::exec() () from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#19 0x4072e270 in createKMessageBox(KDialogBase*, QMessageBox::Icon, QString const&, QStringList const&, QString const&, bool*, int, QString const&) ()
   from /usr/lib/libkdeui.so.4
#20 0x40731061 in KMessageBox::error(QWidget*, QString const&, QString const&, int) () from /usr/lib/libkdeui.so.4
#21 0x0806daf1 in KProfWidget::prepareHtmlPart(KHTMLPart*) ()
#22 0x08068bf0 in KProfWidget::openFile(QString const&, KProfWidget::ProfilerEnumeration, bool) ()
#23 0x08065a7e in KProfWidget::KProfWidget(QWidget*, char const*) ()
#24 0x0806f8a2 in KProfTopLevel::KProfTopLevel(QWidget*, char const*) ()
#25 0x08070877 in main ()
#26 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6"

and I have the following on the command line:
"QFile::writeBlock: File not open
KCrash: crashing.... crashRecursionCounter = 2
KCrash: Application Name = kprof path = <unknown> pid = 6807"

What's wierd is that if I start it without command line arguments, and then use the menu to open the executable, I get the same error box "dot could not display the data (1).", but KProf stays up, and appears to be working except the graph and method view tabs don't show anything.
Any ideas?

I'm running a pretty stock RedHat 8.0 system.
Thanks
Eric