KeePassPPC WM6 V0.5.2 problems

2010-02-23
2013-04-22
  • Stanimir Jordanov

    Hello,

    I've installed KeePassPPC WM6 V0.5.2 on WM 6.1 Professional and it looks like I cannot change group in the tree control with touch (or stylus). Changing group can be done only with Arrow keys of my Touch Diamond and it doesn't refresh the entries list at all.

    I went back to V0.5.1 and all is working fine there.

    Anyway - GREAT WORK! Many thanks!

     
  • Stanimir Jordanov

    Hello,

    I'm using custom ROM. About says:

    Windows Mobile 6.1 professional
    CE OS 5.2.21054 (build 21054.1.6.7)

    I think you should also check the AKU version in HKLM\SYSTEM\Versions\Aku. It is ".1.6.7" on my device.

    Regards,
    Stanimir

     
  • Nobody/Anonymous

    I have the same problem, but I have a factory Sprint Touch Pro2 ROM installed, which is WM6.1… 

    This is my first install of KeePassPPC, no previous versions existed before…

     
  • phubarr

    phubarr - 2010-03-08

    I'd like to append more info, I'm the one who made post #4 above (I just registered an account with SourceForge).

    Under Settings -> About, my Sprint TP2 says:

    Windows Mobile 6.1 Professional
    CE OS 5.2.21052 (Build 21052.1.6.5)

     
  • phubarr

    phubarr - 2010-03-08

    I'd also like to mention something else which I think may be a bug, possibly related to the issue above…

    I've created a new group and added an entry in it, but when I use my arrow keys to highlight the group, I can't seem to get the entry to display in the bottom window (I've tried using the enter key, spacebar, right arrow key, etc to select the group in case it wasn't actively selected).  The only way I can see my entry is if I do a search for it.

    Also, another issue… when I'm first logging in, I enter my password and hit OK, but it doesn't move on.  I have to hit OK twice before it logs me into the program…

     
  • Tobias

    Tobias - 2010-03-09

    *sigh*

    One of the things which makes WM development so painfull is the nasty evil GUI programming from hell.
    You have the base functionality which never offers what you want. Then you find ways to tweak it to make it work. And naturally on the next OS version all the tweaks fall apart.

    Ok as it seems to be impossible to detect "am i running WM 6.5 or not" without writing throusands of lines of codes, clever guessing of version numbers and checking of dodgy AKU registry keys, maybe i should just additionally check for the existence of "PhysicsEngine.dll" and "TouchRecognizer.dll" in the Windows directory. Chances are that if the DLLs are there, we are running a device that supports gestures.

    Bests,
    Tobias

     
  • Stanimir Jordanov

    It's working fine on my phone. I've even left this version in use until the official is released.

    10x :)

    P.S.
    I don't think WM programming (even GUI which is the worst part) is so bad. It's not like Android but try Symbian ;)

     
  • Bennett Lee

    Bennett Lee - 2010-03-17

    I was having same problem.  Debug version lets me select tree now.  Thanks!

    Touch Pro 2, T-Mobile stock 6.1

     
  • Nobody/Anonymous

    Same here - Debug Version solved the Problem!

     
  • Anonymous - 2010-06-07

    the debug version works now on my htc diamond 1, the regular version does not. can you please make a official version of this latest debug version and release it as a *.cab for instllation on the device? would be great. thanks

     
  • phubarr

    phubarr - 2010-06-07

    x2…  I've been using the version released before V0.5.2, waiting for an official release containing this fix…

     
  • Tobias

    Tobias - 2010-06-13

    I released V0.5.3 today. Just contains the fix for WM 6.1 devices as was in the debug build…
    Waiting for WM6.5 to break again now.

    Tobias

     
  • Nobody/Anonymous

    thanks i have downloaded it right now…

     
  • phubarr

    phubarr - 2010-06-14

    Thanks so much, you're awesome!  I'm going to download and install it right now…

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks