Problem with OtpKeyProv on Citrix XenApp

Help
2011-11-28
2013-01-18
  • Marcel de Haas

    Marcel de Haas - 2011-11-28

    Hi all,

    I am currently scrambling to change the authentication method on our KeePass database because it may have been compromised due to a leaked password. We are currently changing all our passwords and I am planning to use one time passwords to open our database. We are on a Citrix platform and I'm having trouble with the plugin. I have added it to the KeePass folder. It runs when I start it as an administrative user, but when I start it in the user context it gives me an error:

    ---------------------------
    KeePass
    ---------------------------
    The following plugin is incompatible with the current KeePass version:
    \\[FILESERVER]\[DOMAIN].[TLD]-home$\[USERNAME]\Windows\Profile.v2\AppData\KeePass\PluginCache\NcEiAiYszkuAagSF_2.1.7.16602\ZZFyO4UE.dll
    Have a look at the plugin's website for an appropriate version.
    ---------------------------
    OK   
    ---------------------------
    

    or depending on where the cache is configured

    ---------------------------
    KeePass
    ---------------------------
    The following plugin is incompatible with the current KeePass version:
    C:\Program Files (x86)\KeePass Password Safe 2\OtpKeyProv.plgx
    Have a look at the plugin's website for an appropriate version.
    ---------------------------
    OK   
    ---------------------------
    

    I am running KeePass 2.17 with OtpKeyProv 1.2 on Windows 2008 R2. I have tried various combinations of the settings but I can't seem to get rid of the error, Also tried setting security (all users modify) on the central cache. Does someone have the magic bullet I'm looking for?

    Best regards,
    Marcel de Haas
    Netherlands

     
  • Marcel de Haas

    Marcel de Haas - 2011-11-28

    Almost forgot I have sequenced KeePass Using App-V, but this also did not provide a solution. I have not tweaked any files in the package, this may also be a vector to the solution.

     
  • Dominik Reichl

    Dominik Reichl - 2011-11-28

    Apparently you've relocated the user's app data folder onto a network share. You need to configure .NET to fully trust the network share, otherwise plugin assemblies aren't loaded. See Caspol.exe (Code Access Security Policy Tool) and Using CasPol to Fully Trust a Share.

    If you don't want to change the .NET security policy, you alternatively can relocate the KeePass plugin cache to some local folder (on the user's hard disk, e.g. to %TEMP%\KeePass-PluginCache). See http://keepass.info/help/v2/plugins.html, section 'Plugin Cache' for details.

    Best regards
    Dominik

     
    • doc

      doc - 2013-01-18

      Hi, I have followed your solution setting the PluginCache directory, but the same message appears every time I start KeePass. I am using Ubuntu, maybe this applies to Windows systems only?

      Thanks

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks