Keepass disables ą key (alt+a).Broken l...

xfthgq5
2012-10-09
2016-10-09
  • xfthgq5

    xfthgq5 - 2012-10-09

    After I Installed Keepass my ą (alt+a) key stopped working. I thought a breadcumb was under alt key so I pulled and broken it. Now I need a new laptop keyboard.

    It was Keepass fault!

     
  • Paul

    Paul - 2012-10-09

    I don't think you can really blame KeePass for breaking your keyboard.  ;-))

    KeePass uses Ctrl Alt A as the Auto-Type hot keys. You can change it in Tools > Options > Integration.

    cheers, Paul

     
  • Piotr

    Piotr - 2012-10-13

    That's a known issue with for example the Polsh keyboard layout.
    As though only "ą" is not workig and Alt an A are working so this should be assosiated with software and not hardware.
    By the way - in what other languages is the "ą" used (apart from Polish)?

    3 years ago I have suggested a small workarroud:
    https://sourceforge.net/tracker/?func=detail&aid=2814031&group_id=95013&atid=609911

     
  • derbeth

    derbeth - 2016-05-06

    @Paul: can we get back to the topic?

    KeePass breaks system of every Polish user immediately after being installed. Right Alt+A will be used to type an accented character all the time by a Polish user. I know the shortcut can be changed in KeePass settings, but 1) even smart people may now know that Right Alt translates to Ctlr+Alt - this is completely unintuitive 2) they may not connect breaking 'ą' letter with installing KeyPass 3) good software has a configuration with good defaults.

    I suppose the global shortcut for auto-type is not the thing the majority of KeePass users use. Even if it is - it's better to make a user who uses it change the configuration (you seemed to suggest it is not a problem) than make a group of users waste time finding out what broke their system. We are not talking about some cosmetic change that is controlled by an option, we are talking about a default option that makes your system unusable. There should be no such default options.

    If you really don't want to touch this option, you should at least check user locale during installation and assure that the default global shortcut for pl_PL is not set.

     
  • Paul

    Paul - 2016-05-07

    Wow, a 6 year old thread. Nice to see someone searches before posting.

    Maybe the best method would be to offer to change the hot key if a user changes the language file?

    cheers, Paul

     
  • Dominik Reichl

    Dominik Reichl - 2016-10-09

    I've now added a check for KeePass 2.35. If the global auto-type hot key is Ctrl+Alt+A and if this is in conflict with a system key combination producing a character, KeePass now shows a warning dialog (with a hint where to change the global auto-type hot key).

    The check is only performed in this very specific case. In all other cases, KeePass assumes that the user is aware of a possible conflict and intentionally wants to override any system key combination.

    Here's the latest development snapshot for testing:
    http://keepass.info/filepool/KeePass_161009.zip

    Thanks and best regards,
    Dominik

    PS: The documentation mentioned this possible conflict on Polish systems for a long time already, and it will continue to do so, because KeePass 1.x doesn't perform a check.
    http://keepass.info/help/base/faq_tech.html#athotkey

     

Log in to post a comment.