#136 ".svn" directories should not end up in build

none
open
nobody
5
2009-11-12
2009-09-26
jfirechief
No

DO NOT EDIT OR ANSWER THIS ISSUE. SEE THE ORIGINAL ISSUE INSTEAD:
https://www.jfire.org/modules/bugs/view.php?id=1251
ORIGINAL REPORTER: marco

Those directories which are in SVN and directly packed into the JARs (e.g. "META-INF", "icons" or "schema"), are copied together with their ".svn" subdirectories. The SVN meta-data should not end up in the nightly build products, though.

You can see this (wrong) packaging behaviour when simply opening any RCP-client-plugin-JAR. The server's JARs seem not to be affected (but I'm not 100% sure).

Discussion

  • jfirechief

    jfirechief - 2009-09-26
    • labels: --> Nightly Build
    • milestone: --> none
    • summary: ".svn" directories should not end up in build --> ".svn" directories should not end up in build
     
  • jfirechief

    jfirechief - 2009-09-26

    ORIGINAL COMMENT BY marco, VIEW IT HERE:
    https://www.jfire.org/modules/bugs/view.php?id=1251

    Hi Marc,

    again I'm assigning this issue to you, because you're the build-system-god ;-)

    Please either fix it or give me an introduction to the new build system. Alternatively, you might want to write some documentation about the build system into our wiki... (I just looked into it and it seems there are only docs for the old build).

    Best regards, Marco :-)

     
  • jfirechief

    jfirechief - 2009-09-26

    ORIGINAL COMMENT BY Marc, VIEW IT HERE:
    https://www.jfire.org/modules/bugs/view.php?id=1251

    I will work on it when I have time to do so.

    I can introduce the new build system to you when you are back in Germany and I have time to do so.

    I will write documentation about it when I have time to do so.

     
  • jfirechief

    jfirechief - 2009-11-12
    • summary: ".svn" directories should not end up in build --> ".svn" directories should not end up in build
     
  • jfirechief

    jfirechief - 2009-11-12

    ORIGINAL COMMENT BY marco, VIEW IT HERE:
    https://www.jfire.org/modules/bugs/view.php?id=1251

    Hi Marc,

    again I'm assigning this issue to you, because you're the build-system-god ;-)

    Please either fix it or give me an introduction to the new build system. Alternatively, you might want to write some documentation about the build system into our wiki... (I just looked into it and it seems there are only docs for the old build).

    Best regards, Marco :-)

     
  • jfirechief

    jfirechief - 2009-11-12

    ORIGINAL COMMENT BY Marc, VIEW IT HERE:
    https://www.jfire.org/modules/bugs/view.php?id=1251

    I will work on it when I have time to do so.

    I can introduce the new build system to you when you are back in Germany and I have time to do so.

    I will write documentation about it when I have time to do so.

     
  • jfirechief

    jfirechief - 2009-11-12

    ORIGINAL COMMENT BY Marc, VIEW IT HERE:
    https://www.jfire.org/modules/bugs/view.php?id=1251

    The server modules are created by WTP. The RCP-plugin modules are created by custom code as the PDE integration is awful.

    Ignoring .* as long as not explicitly configured in build.properties may be a solution. But first, we should look inside WTP what mechanisms prevent those files to end in the jars.

    There may be some Eclipse internal mechanism (Maybe the same mechanism Subversive uses to avoid auto-check-in of some files)

     

Log in to post a comment.