Unable to fetch server id_key

  • Jeanneret Internux

    I just tried this lib on a dedicated server, but I have this error :
    FAILED to read id_key from server.

    Then, google redirect me on the login window, so I can't go ahead.

    I tried diagnose.php, but all is clear.

    My aim : get contacts informations.

    Here's my code :

    $gmailer = new GMailer();

    if($gmailer->created) {


        if($gmailer->connect()) {


            $snap = $gmailer->getSnapshot(GM_CONTACT);

        } else {
            echo 'Failed to connect : <br />'.$gmailer->lastActionStatus();
    } else {
        echo 'Failed to create GMailer because : <br />'.$gmailer->lastActionStatus();

    Seems to be the only error in logs. No error reported from cURL [I activated error reporting in libgmailer]

    Versions :
    PHP Version 4.4.7-pl0-gentoo
    libgmailer 0.9.0 beta 8
    curl 7.15.1-r1 (gentoo stable)

    Thanks in advance !

    • Jeanneret Internux

      I've forced cookies usage... BUT, now, I've another problem:
      it fails on
      $snap = $gmailer->getSnapshot(GM_CONTACT);

      I've put a debug output, and it gives me :
      <?php /** libg110 **/ ?>
      <?php /** Snapshot: Using Cookies, saving id_key(ik)... **/ ?>
      <?php /** Snapshot: Cookie id_key NOT saved.  $raw["ud"][3] not found. **/ ?>

      Seems that I'm not logged in... Do you have a solution?


    • neerav

      neerav - 2007-11-14

Log in to post a comment.