Can't access media directory

Help
2006-12-05
2013-04-25
  • Lari Pelkonen

    Lari Pelkonen - 2006-12-05

    This might be a stupid question, but how can I assign shared directories to Fuppes? I started Fuppes (on Fedora 5) and configuration page seems to be working on browser. Everything works except shared directory part. I inserted my mp3-directory and pushed submit button. Nothing. I Fuppes shows on my Nokia 770 thru D-Link 604 router, but I can't access media directories. Configuration page shows empty table (blue) where directories should be. Fuppes version is 0.5.4.

    Web page sends form information to Fuppes and my directory is listed on debug output. No error messages, just empty directory list. I tried to add directories to cfg-file by typing them, but that didn't work either. I inserted them between <dir> tags. Is that correct?

    Well positive thing is that Fuppes works via D-Link G604T wireless router. I'm just too stupid to make it play things.

     
    • Ulrich Völkel

      Ulrich Völkel - 2006-12-05

      Arrghh... I have an idea what causes the problem. The "AddSharedDirectory" wich adds a new shared dir to the config file tries to convert the passed value to UTF-8. And if the conversion fails an empty string is written. It uses the wrong conversion function.
      What was the exact string you tried to insert?
      What is your local charset?
      Can you please try to add a directory name containing plain ASCII characters. e.g /home/test

      But this does not explain why manually added dirs are not shown. Maybe you edited the config file while fuppes was running? Fuppes must not run while editing the config file manually. Also make sure you save it with UTF-8 charset.

      Maybe you can mail me a config containing some directory entries that are not shown.
      mail AT ulrich-voelkel.de

      thanks for reporting! best regards,
      Uli

       
    • Lari Pelkonen

      Lari Pelkonen - 2006-12-11

      Thanks for answering. I'm afraid it's not the conversion that fails (at least because illegal chars). My directory-path is quite simple (I tried /data/mp3/ and /tmp/ and few other directory paths). Unless it is / -characters that causes problems. My local character set is ISO 8859-1. I tried editing cfg-file with Fuppes running and without.

      One thing I forgot to mention. I removed comment tags around shared directory tags. Fuppes crashed if I left those intact. It reported about memory overflow.

       
    • Ulrich Völkel

      Ulrich Völkel - 2006-12-15

      > I removed comment tags around shared directory tags. Fuppes crashed if I left those intact. It reported about memory overflow.

      Can you please post the exact error message. Seems to be a problem with the libxml2. What libxml2 version are you using? xml2-config --version

      greets,
      uli

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks