Menu ▾ ▴

#80 Verbosity setting not working?

duply
closed-invalid
nobody
None
5
2017-06-27
2015-05-07
sinklar
No

Hello,

I tried every possible value for the verbosity setting but it looks like I always get the exact same content by email and each time. Is it normal? I thought that by changing the verbosity setting, I would get notifications to just show that there was no error.

Related

Bugs: #80

Discussion

  • ede

    ede - 2015-05-07

    On 07.05.2015 09:58, sinklar wrote:


    [bugs:#80] http://sourceforge.net/p/ftplicity/bugs/80 Verbosity setting not working?

    Status: open
    Group: duply
    Created: Thu May 07, 2015 07:58 AM UTC by sinklar
    Last Updated: Thu May 07, 2015 07:58 AM UTC
    Owner: nobody

    Hello,

    I tried every possible value for the verbosity setting but it looks like I always get the exact same content by email and each time. Is it normal? I thought that by changing the verbosity setting, I would get notifications to just show that there was no error.

    what is your cmd line.. eg.
    duply <profile> status -v9
    works fine for me.</profile>

    what's your duply version? ..ede

     

    Related

    Bugs: #80

  • sinklar

    sinklar - 2015-05-11

    I have Duply 1.9.1 installed.

    The cron command is "duply daily backup". The output isn't affected when I change the verbosity setting in the "conf" or via the command with -v1

     
  • ede

    ede - 2015-06-21
    • status: open --> closed-invalid
     
  • Stefan Seidel

    Stefan Seidel - 2016-08-21

    I think the problem is that it doesn't seem to be possible to lower the verbosity level in a meaningful way. If daily backups are scheduled, then it would be good to only have output if warnings (-v2) or errors (-v0) occur. However, even with -v0 and VERBOSITY=0 in the conf file, I get this output:

    Start duply v1.9.1, time is 2016-08-21 20:49:11.
    Using profile '/root/.duply/100'.
    Using installed duplicity version 0.7.06, python 2.7.9, gpg 1.4.18 (Home: ~/.gnupg), awk 'mawk 1.3.3 Nov 1996, Copyright (C) Michael D. Brennan', bash '4.3.30(1)-release (x86_64-pc-linux-gnu)'.
    Autoset found secret key of first GPG_KEY entry 'E3BXXXX' for signing.
    Checking TEMP_DIR '/tmp' is a folder (OK)
    Checking TEMP_DIR '/tmp' is writable (OK)
    TODO: reimplent tmp space check
    Test - Encrypt to 'E3BXXXX' & Sign with 'E3BXXXX' (OK)
    Test - Decrypt (OK)
    Test - Compare (OK)
    Cleanup - Delete '/tmp/duply.27348.1471805352_*'(OK)
    
    --- Start running command PRE at 20:49:12.369 ---
    Skipping n/a script '/root/.duply/100/pre'.
    --- Finished state OK at 20:49:12.384 - Runtime 00:00:00.015 ---
    
    --- Start running command BKP at 20:49:12.397 ---
    Warning: Option --exclude-globbing-filelist is pending deprecation and will be removed in a future release.
    --include-filelist and --exclude-filelist now accept globbing characters and should be used instead.
    --------------[ Backup Statistics ]--------------
    StartTime 1471805358.28 (Sun Aug 21 20:49:18 2016)
    EndTime 1471805365.95 (Sun Aug 21 20:49:25 2016)
    ElapsedTime 7.66 (7.66 seconds)
    SourceFiles 34137
    SourceFileSize 757727723 (723 MB)
    NewFiles 6
    NewFileSize 272226 (266 KB)
    DeletedFiles 0
    ChangedFiles 5
    ChangedFileSize 50871 (49.7 KB)
    ChangedDeltaSize 0 (0 bytes)
    DeltaEntries 11
    RawDeltaSize 252472 (247 KB)
    TotalDestinationSizeChange 14418 (14.1 KB)
    Errors 0
    -------------------------------------------------
    
    --- Finished state OK at 20:49:38.005 - Runtime 00:00:25.608 ---
    
    --- Start running command POST at 20:49:38.018 ---
    Skipping n/a script '/root/.duply/100/post'.
    --- Finished state OK at 20:49:38.034 - Runtime 00:00:00.015 ---
    

    but the manual suggests at levels 0 and 2 there should only be errors and warnings:

    --verbosity level, -vlevel
        Specify output verbosity level (log level). Named levels and corresponding values are 0 Error, 2 Warning, 4 Notice (default), 8 Info, 9 Debug (noisiest). 
    
     

    Last edit: Stefan Seidel 2016-08-21
  • Schroeffu

    Schroeffu - 2017-06-27

    I have exactly the same problem. Goal would be receive only cronjob duply mail, if there are warnings and/or errors.

    -v1 or --verbosity 1 or VERBOSITY=1 in conf, all of them are not working. The output is still the full status as described above by Seidel.

    Now, what to do, to only receive cronjob mails if a backup job fails?

     

Log in to post a comment.