mged bus error on Mac OS X

  • Ilougino Rocha

    Ilougino Rocha - 2009-05-17

    Hi, I just downloaded the latest(7.12.2) brl-cad binary distribution for mac ox 10.5 have had no success getting mged started.  When I launch the program, it dies with a BUS error a few seconds after startup.  I tried an older version(7.10.4) and it had the same issue.  Then I downloaded the latest source and built it(with a little trouble because tclhtml was not linking to X11 libs), and it still has the same issue.  I ran it in the debugger and it seems to crash in libdm/dm-X.c:343.  It looks like the pubvars->dpy->screens is null.  If anyone knows of anyone knows of anything that might be leading to this, it would be greatly appreciated. Note that if i specify a non-existing database file name, it pops up a dialog prompting to create it and then dies.  In case the fact that it can display the dialog is significant.   Thanks in advance.

    • Sean Morrison

      Sean Morrison - 2009-05-17

      Please post a report to our bug tracker with a full stack trace:

      It would also be *really* useful for you to try our latest SVN sources instead of a checkpoint release so we can iterate on a few possible fixes/tests.  I just applied a few sanity checks around dm-X.c:343 that should be informative (and minimally should prevent a crash).

      One sanity thought though.. is X11 already running when it crashes?  Macs are bit bipolar when it comes to Tk windows and X11 initialization given they can also try to go through Aqua.


    • Ilougino Rocha

      Ilougino Rocha - 2009-05-18

      Great thanks.  I'm checking out from svn now.  Will post after i get a build.  Note that I was able to install the package on my wife's more recent macbook with no problems.


Log in to post a comment.