no module named wx in fresh linux install

Help
Chelonian
2010-03-30
2013-05-01
  • Chelonian

    Chelonian - 2010-03-30

    This is frustrating.  After quite a while with an Ubuntu Intrepid install working fine, I reinstalled Ubuntu (hoping to cure some crashing issues…turns out that was probably a wireless network bug and the reinstall was unnecessary) and now I can't get Boa set up properly.  What I've done is this:

    1) Installed wxPython 2.8.10 from the wx repositories, as directed on the wxPython site.
    2) Downloaded Boa 0.6.1-4 from Sourceforge and tried extracting it to either the desktop, the user's home folder, or, using privileges, to site-packages (none worked).
    3) Associated Boa.py in the Boa folder to open with Python.

    Problem is, Boa starts fine, but any app, even the simplest test app, will give the error:  'No module named wx'.

    I'm fairly sure I had Boa running with wxPython 2.8.10 previously, but I can't remember what the trick to this is.  Any ideas anyone?  (If I download Boa from the Ubuntu repositories, I can get farther, but it is frozen at wx2.6, which doesn't even have wx.combo yet, so it's really not an option).

    Thanks,
    Che

     
  • KingRabby

    KingRabby - 2011-11-09

    i have the same problem can anyone help please :(

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks