Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Still can't create a browser

Help
2012-06-15
2013-10-02
  • I was using RSSOwl 2.1.2 and the latest Firefox version fine until last night
    when I decided to update my Ubuntu to 12.04.

    Now RSSOwl tells me it can't create a browser anymore, no matter what I set
    for the browser in the settings.

    I found
    http://www.rssowl.org/help#item_6j and
    downloaded the XULRunner linked from there and put it under /opt/xulrunner.
    Then I tried starting it with the following command:

    /opt/rssowl/RSSOwl -vmargs
    -Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner

    But it still tells me the same thing and changing the settings still doesn't
    have any effect either. I also don't see any errors in the console that would
    suggest that something in my setup is wrong.

    Is there any other info I can provide that would help solve my issue?

    Thanks!

     
  • genodeftest
    genodeftest
    2012-06-17

    The 2.1.2 Release should work fine on Ubuntu 12.04. It contains a private
    xulrunner 1.9.2.x since RSSOwl does not (yet) support xulrunner versions >=
    2.x. Which version of libhunspell do you have installed? Since every version
    of xulrunner depends on a specific version of libhunspell, this could be the
    reason.

     
  • genodeftest
    genodeftest
    2012-06-17

    you should be able to locate libhunspell with synaptics package manager or
    with apt-get from command line. If it is version >= 1.3, you should create a
    symlink from its current location to the same folder but with version 1.2,
    just like this:

    ln /usr/lib64/libhunspell-1.3.so.0 /usr/lib64/libhunspell-1.2.so.0
    

    worked for me in Fedora 16 where libhunspell-1.3.so.0 is located in
    /usr/lib64.

    If you have a 64Bit Ubuntu, your libhunspell 1.3 should be in /usr/lib/x86_64
    /linux-gnu, so you will need to replace both paths /usr/lib64 with that:

    ln /usr/lib/x86_64/linux-gnu/libhunspell-1.3.so.0 /usr/lib/x86_64/linux-gnu/libhunspell-1.2.so.0
    

    (you will need higher privileges, e.g. sudo to do that. But think first if it
    is the right thing to do)

     
  • Yay, that worked! Thank you very much, I can read my news again. :-D

    I indeed had version 1.3.2-4 of libhunspell installed. The path is
    /usr/lib/x86_64-linux-gnu but otherwise, yeah, worked exactly as you said.

     
  • Jelio Jelev
    Jelio Jelev
    2013-10-02

    Works in 64bit Ubuntu 13.04 for 64bit RSSOwl but directories are wrong. If doesn't work for you, check directories for package libhunspell in synaptic. You need libhunspell-1.3.so.0 exact location. Here is my command:

    sudo ln /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0 /usr/lib/x86_64-linux-gnu/libhunspell-1.2.so.0

     
    Last edit: Jelio Jelev 2013-10-02