File Based Voltage Source

Help
Leon
2008-06-25
2012-12-15
  • Leon
    Leon
    2008-06-25

    Does anyone know what the format for the file based Voltage source is.  Also how do you get it to work with the proper frequency is using it on repeat.  Is there anything special needed to be done to get it to work in simulations?

    Thank you for your help.

    James Leon

     
    • Stefan Jahn
      Stefan Jahn
      2008-06-26

      Hi!

      Use the CSV (comma separated values) file format.  First column time, then voltage value.  Repetition is done by repeating the whole sequence after the CSV ends.

      HTH, Stefan.

       
    • Jürgen Eckert
      Jürgen Eckert
      2008-07-08

      Hello all together,

      would be nice to have an example of such vfile.dat that's allready running.
      I allways get a "qucsator.exe´"-error with an additional report to Microsoft. But they won't help :-)

      Does anyone have such example?

      greetings

      Jürgen

       
    • Stefan Jahn
      Stefan Jahn
      2008-07-10

      Hello Jürgen,

      About your request:  I setup something and uploaded it to <http://qucs.sourceforge.net/examples.html>.  Anyway, Can you please send me your (non-working) example, that I can probably fix the error?

      Thanks in advance, Stefan.

       
    • Jürgen Eckert
      Jürgen Eckert
      2008-07-14

      Hello Stefan,

      it works! thanks a lot.

      Finally I used an Excel-Sheet to descibe the Time-to-Voltage dependancy. After entering the data-pairs in Excel, the sheet can be stored in *.csv format and just called from QUCS by entering the filename (file.csv) into the databased-voltage-source. For me, this is a comfortable way.

      thanks again and best whishes

      Jürgen

       
    • Stefan Jahn
      Stefan Jahn
      2008-07-14

      Hello Jürgen,

      nice that you're comfortable with it...

      Once again:  Are you able to send me the schematic+datafile for which you "I allways get a "qucsator.exe´"-error with an additional report to Microsoft" get this message?  It refers to a segfault.  This is why I would like to fix it...

      Thanks, Stefan.