#4380 (ok 4.2.1) Cannot display table structure with enums containing special characters

4.1.12
fixed
None
1
2014-05-13
2014-04-25
Marc
No

create the following table:
CREATE TABLE rdShopItems (
ID int(10) unsigned NOT NULL AUTO_INCREMENT,
GefahrGesund enum('','Sehr giftig','Giftig','Gesundheitsschädlich') COLLATE latin1_german1_ci NOT NULL,
GefahrReiz enum('','Ätzend','Reizend') COLLATE latin1_german1_ci NOT NULL,
GefahrUmwelt enum('','Umweltgefährlich') COLLATE latin1_german1_ci NOT NULL,
PRIMARY KEY (ID)
) ENGINE=MyISAM

table creation is correct, if you try to select the table you get "Error, Code 200, Ok".

Discussion

  • Hi,

    Here is a more simple "CREATE TABLE" to understand what is the issue:
    CREATE TABLE f4380 (
    field enum('0123456789012345678901234567890123456789012ä')
    ) ENGINE=MyISAM;

    The issue is due to the ä (or any character of extend ASCII codes: http://www.asciitable.com/) in 50th position.
    If this character is in 49th position, there won't be any error neither in 51th position.

    I hope it can help…

     
  • Marc Delisle
    Marc Delisle
    2014-04-27

    • summary: phpmyadmin refuses to show tables with enums containing special data --> Cannot display table structure with enums containing special characters
    • assigned_to: Hugues Peccatte
     
  • Marc Delisle
    Marc Delisle
    2014-04-27

    • summary: Cannot display table structure with enums containing special characters --> (ok 4.2.1) Cannot display table structure with enums containing special characters
    • status: open --> resolved
    • Priority: 9 --> 1
     
  • Marc Delisle
    Marc Delisle
    2014-05-13

    • status: resolved --> fixed