Why can't I log in 4.2

Help
2009-02-17
2013-05-30
  • After several new installations I'm out of solutions, hopefully ine of you will be so kind to help me out?

    A brand new installation of PGV 4.2 in the right directory with the right permissions.
    After uploading GEDCOM all works fine, I can tune ervery item to my wishes.
    I can make new users a set the priveleges for them without any problem
    I can see everything, I can do everything.

    So far so good.

    Logout, everything seems oké.

    But if I wish to log with any of the known users, PGV says "Unable to authenticate user."

    I'm sure I put in the right name and password, but there is something I've done wrong.

    Please, probally something small but who will/can me this?

    With regards,

    Martin

     
    • Gerry Kroll
      Gerry Kroll
      2009-02-17

      In PGV, userids and passwords are case sensitive.  "Userid" is not the same as "userid" or "USERID".

      In the site configuration, you need to leave the login url and site url fields blank.  PGV will probably try to fill in the site url field -- that's OK, although it should REALLY be blank.

       
      • Thanks Gerry,

        I followed your advise, in the beginning it seems working as all earlier installs, but at the moment I log off and log in again,
        I get the same message as in earlier situations; "Unable to authenticate user."

        with regards,

        Martin

         
        • Hate to return to this topic, but I've been having the same problem, and nothing seems to work. 

          My user name/ID (I think) is my name, separated with spaces.  Everything worked when I originally set up the account last month; but I wrote my user name and password on a slip of paper.  (okay - bad idea). 

          Nevertheless, you can usually get a new name and a new password for most applications using the e-mail account you used to set up the application: youtube, myspace, etc. 

          I have been able to successfully request new passwords for phpgedview two times, but neither of the new passwords work.  I still get the same "unable to authenticate" message. 

          I tried setting up a new user account, but couldn't log-in to authenticate the new user. 

          This is the text of a typical reply to a request for data:

          < ======================================= >

          Hello xxxxxxx Logan xxx ...

          A new password was requested for your user name.

          User name: xxxxxxx Logan xxx
          Password: zzzzzzzz

          Recommendation:
          Please click on the link below or paste it into your browser, login with the new password, and change it immediately to keep the integrity of your data secure.

          After you have logged in, select the My Account link under the MyGedView Portal menu and fill in the password fields to change your password.

          http://www.yyyyy.org/phpgedview

          < ======================================= >

          When I follow those instructions, and enter the user name and password; I still get the "Unable to authenticate" message.  (I also tried clearing cookies, to account for possible site security issue for repeated log-in attempts).

          Thanks,

          Logan

           
    • Gerry Kroll
      Gerry Kroll
      2009-02-17

      Martin:
      Please e-mail me at gkroll at keldine dot ca

      I'll need the following information:
      (a) URL to your site
      (b) admin userid
      (c) password for (b)

      I'll probably also need to FTP into your site to check a few things.  Thus, I'll need the FTP userid and password too.

      Thanks.

       
    • Gerry Kroll
      Gerry Kroll
      2009-02-17

      I received the requested information and was able to work around the problem.

      There's a bug in PGV:  When logging in, PGV will not accept a password that contains "&".  The "&" is acceptable in passwords when creating or updating users.

      The bug is NOT YET fixed.

       
    • hey Gerry,

      One again thanks for all the work you've done, it's works fine to me now.

      I've send you a pm with another minor problem inside PGV4.2, it's about spaces between given- & familynames.

      Keep up the good work.

      greetz, Martin

       
      • Greg Roach
        Greg Roach
        2009-02-18

        <<about spaces between given- & familynames.>>

        If you've got names like this

        1 NAME John/SMITH/

        Then PGV will not automatically add a space between John and SMITH.

        This is an intentional change.  Adding a space is wrong in certain languages/scripts.

        Since one or more desktop applications generates data in this format, there is a "batch update" which will go through your gedcom and convert

        1 NAME John/SMITH/

        to

        1 NAME John /SMITH/

         
  • Hi, back again.  I just wanted to figure out how to remove all of the "ERROR 2" messages on all of my pages, so I could print individual cards of individual family members without all of the clutter at the top.  I tried to log-in.  I got a full page of "ERROR 2" messages.  There was no GedViewPortal and there weren't any links out. 

    I even requested and received a new password.  Same results: a page of "ERROR 2" messages with the URL:

    http://www.dmoma.org/phpgedview/login.php

    What am I doing wrong? 

     
  • This is my website:

    http://www.dmoma.org/phpgedview/

    I wish I knew how to get rid of all of the ERROR 2 messages…

     
  • Gerry Kroll
    Gerry Kroll
    2011-04-07

    It looks as if whoever set up your server's PHP installation did not configure the systemp's php.ini file correctly.

    Specifically, the PHP configuration directive session.save_path needs to point to a directory that exists and is writable.  In your case, the directory /var/php_sessions probably doesn't exist or is not writable.

    PhpGedView has a site configuration setting that can overcome this problem.  You can specify an overriding value, such as ./index/ .  You do this by launching the site configuration wizard from the Admin menu and entering the desired value into the Session save path field.  This field is in the Install Step 4 group of options.

    If necessary, you can download the file "config.php", make the change locally, and then upload it again.  The variable to look for is $PGV_SESSION_SAVE_PATH

     
  • Stephen Arnold
    Stephen Arnold
    2011-04-07

    Logan
    You or your host have not set the proper location or permissions on a SESSIONS folder via your PHP configuration.
    in case of this problem, PGV lets you set your own if your PHP had not set a default folder. I would recommend creating a SESSIONS folder in your INDEX folder, with full read/write permissions, and point to this new folder in the PGV configuration.
    -Stephen