Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Accept all GEDCOM changes

Help
Han
2012-08-07
2013-05-30
  • Han
    Han
    2012-08-07

    Accepting all GEDCOM changes gives allways an error:

    Beoordeel GEDCOM-wijzigingen
    Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\phpgedview\includes\classes\class_pgv_db.php on line 835

    Accepting one single change takes about 30 seconds and I have a few 1000's records.

     
  • ggpauly
    ggpauly
    2012-08-07

    Hi Han,

    Shouldn't take 30s to accept a change.  Something's wrong with your installation.

    You have a possibly related problem in another thread. 

    You said 1000's of records - is this records with changes or total records in your database?

     
  • Gerry Kroll
    Gerry Kroll
    2012-08-07

    Han:
    It's possible that updates to your database are taking so long because the configuration specifies that all database changes should be copied to the GEDCOM file to keep it current with the database.

    This is NOT a good idea when there are many changes that need to be applied at once.  Each change requires the entire GEDCOM to be copied at least twice.  This will use up a LOT of computer time and is also not very good for the hard drive.

    You will find the relevant option here:  I'll use the Dutch terminology, since you're working entirely in Dutch right now.

    1. Log in as Administrator and click Beheren at the top of the page.  This will launch the Beheer page.

    2. Click the Beheer GEDCOM-bestanden en privacy-instellingen menu option.  This is in the left column, 3rd from the top.  This will launch the Huidige GEDCOM-bestanden page.

    3. On the line Instellingenbestand, click Wijzig.  This will launch the GEDCOM-instellingen page.

    4. Click on the + in front of Opties voor wijzigen to open the Edit options list.

    5. Change the Synchronseer wijzigingen naar GEDCOM bestand option to Nee

    6. Click on any Instellingen opslaan button to save the changes.

    Note:  If your time limit still runs out after 60 seconds (it shouldn't be doing this!), increase the time limit in the configuration.  Proceed as above, but find the time limit in the last option of the Basisinstellingen option list.

    If, after all that, you are still running into problems, please e-mail me a copy of the original GEDCOM produced by Aldfaer.  I can change the incorrectly formed 1 NAME records for you and then e-mail the updated GEDCOM back to you.  You already have the e-mail address.