Howto use biblatex in Kile

  • kernie23


    according to the changelog of Kile the support for biblatex is implemented.

    However, I cannot succeed in using it in the way I could use Bibtex (automatic call of bibtex after pdflatex execution).

    My environment is:
    Qt: 4.8.5
    KDE Development Platform: 4.10.5 "release 4"
    Kile: 2.1.3
    Texlive: 2012 and the development version 2013

    I have following MWE:

    % \usepackage[citestyle=authoryear,backend=biber]{biblatex}


    and the biblatex.bib file is:

    author = {Gozani, T.},
    journal = {Nukleonik},
    year = {1962}

    I first tried the PDFLatex compile button, which results in:
    Package biblatex Warning: Please (re)run BibTeX on the file(s):
    (biblatex) MWE
    (biblatex) and rerun LaTeX afterwards.

    Then I changed the Configuration setting in Settings -> Configure Kile -> Tools -> Build -> Bibtex from Default to 8bit Version. Same result as before.

    Several discussions in the web report an Biblatex item in the Build tool list, or even in the Configuration list mentioned before. Haven't seen it.

    Latest attempt was recompiling latest Kile from the master tree with reinitilized settings. Same result.

    Can somebody help me to correctly use biblatex within Kile?

    Thank you,