Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#337 uAlertMe only connects once and is unstable

v0.76
closed-fixed
Peter Easdown
Remote (15)
5
2014-08-30
2011-12-09
Harold H
No

Hi
I really appreciate iAlertU (IA) and accompanying uAlertMe (UA) app, but I have troubles using it.
I'm using the latest versions 0.76 and ??? (uAlertMe does not indicate it's version)

First of all: it has been quite a hassle to connect my MBP with the iPhone. Finally I got it working, fiddling with different connection types (TCP and Bonjour). I selected my MBP from the selection wheel in UA
When I connect to the MBP with UA, I get a connection after a few seconds and I am able to lock and unlock my MBP.
But when I stop the app and then return, UA is not able to find my MBP again
When I tap on the Wi-Fi circle on top, UA crashes.
When I try to reconnect by tapping on Verbind (=Connect), it doesn't connect anymore and times out after a long time (± 75 seconds) (with a weird Dutch text by the way: "Verband met Mac verloor." and a subtext: "Niet om overbinding". This should be something like "Verbinding met Mac verloren." and "Niet verbonden"

Looking at the console messages it looks like IA is not able to recognize the reconnection request, coming from the same iPhone and thereby rejecting it.

Only by selecting TCP/IP as connection type in IA and reconnecting it again, I am able to reconnect after a while.

Please make the connection more intelligent and robust, as this problem doesn't allow me to use the UA app in a reliable way.

Info from Console:

09-12-11 10:38:28,112 iAlertU: restarting server
09-12-11 10:38:28,114 Firewall: iAlertU is listening from 0.0.0.0:61400 proto=6
09-12-11 10:38:28,114 Firewall: iAlertU is listening from ::ffff:0.0.0.0:61400 proto=6
09-12-11 10:38:36,632 Firewall: Allow iAlertU connecting from 192.168.1.2:49283 to port 61400 proto=6
09-12-11 10:38:36,636 iAlertU: connection established by handler: <GCDAsyncSocket: 0x57dec0>
09-12-11 10:38:36,679 iAlertU: received length: 511
09-12-11 10:38:36,686 iAlertU: received message: AuthenticateMessage
09-12-11 10:38:36,687 iAlertU: sending message with length: 296
09-12-11 10:38:36,702 iAlertU: received length: 295
09-12-11 10:38:36,706 iAlertU: received message: RequestStateMessage
09-12-11 10:38:37,241 iAlertU: sending message with length: 932
09-12-11 10:39:35,936 iAlertU: connection lost by handler: disconnected
09-12-11 10:39:35,936 iAlertU: Server connection
09-12-11 10:39:35,936 iAlertU: waitForNetwork
09-12-11 10:39:40,937 iAlertU: Network is now available
09-12-11 10:39:40,937 iAlertU: restarting server
09-12-11 10:39:40,938 Firewall: iAlertU is listening from 0.0.0.0:61400 proto=6
09-12-11 10:39:40,938 iAlertU: Error in acceptOnPort:error: -> Error Domain=NSPOSIXErrorDomain Code=48 "Address already in use" UserInfo=0x5cbef0 {NSLocalizedFailureReason=Error in bind() function, NSLocalizedDescription=Address already in use}
09-12-11 10:40:22,862 iAlertU: restarting server
09-12-11 10:40:22,863 Firewall: iAlertU is listening from 0.0.0.0:61400 proto=6
09-12-11 10:40:23,908 iAlertU: restarting server
09-12-11 10:40:23,908 iAlertU: Error in acceptOnPort:error: -> Error Domain=NSPOSIXErrorDomain Code=48 "Address already in use" UserInfo=0x5c37c0 {NSLocalizedFailureReason=Error in bind() function, NSLocalizedDescription=Address already in use}
09-12-11 10:40:23,910 Firewall: iAlertU is listening from 0.0.0.0:61400 proto=6

Discussion

  • Peter Easdown
    Peter Easdown
    2011-12-11

    • assigned_to: nobody --> ezsource
    • status: open --> open-accepted
     
  • Peter Easdown
    Peter Easdown
    2011-12-11

    Thanks for the excellent information. First off, to get the current version of UA, tap the "uAlertMe" text on the main screen. It used to display the version there, but I moved it to a popup.

    It seems that a number of people find it hard to get the two apps to talk. I don't quite understand this; as I've really tried to make it simple, especially with the latest versions of UA that allow you to browse the bonjour instances of IA.

    You're obviously using TCP/IP not bonjour, so this would make it a little more difficult as UA can't browse for a TCP server as easily. Are the docs on the pkclsoft.com website not helpful?

    Regarding the reconnection issue; thanks for reporting it. It's something that I though was already fixed. I'll look at it for the next version of IA, which shouldn't be too far off as a kind supporter has contributed Italian translations.

    The Dutch in UA is a merge of what I've been able to take from IA, and some help from Google, so sorry if it's not perfect. If you're happy to contribute, I can email you the strings file for UA for correction.

    Regarding instabilities in UA, please obtain the crash logs and email them through to me for analysis. there is a known issue in v1.5 when you have "save photos" or "save screenshots" enabled. I've already submitted v1.6 to fix this, but that's up to 7 days away from release. Your crashes might be something else, so if you can send them through it would be really helpful.

    Thanks again for your time.

    ezsource

     
  • Harold H
    Harold H
    2011-12-12

    This morning I have retried to get the crashes that I got before. I changed the connection type back to Bonjour again as I have tried that as well.
    I'm not sure what I have changed, but it appeared that I was able to connect repeatedly this time!
    The first time UA crashed when I pressed a button, but after reconnecting again, I was able to connect, disconnect, arm and disarm several times.
    The only thing that I had to change was the diagnosis setting on the iPhone in order to collect crash files there for you. I wasn't sure how to collect crash files from they iPhone for you though. Does Apple send them to you automatically, or can I collect them with a too like iExplorer?
    Oh, and I am on a different network today. Maybe that's a factor too
    I will keep trying in the coming weeks in order to find out what makes the connection between IA and UA unstable.

    I wil be happy to help you with the translation of UA, so please send them to me and I'll do my best.

     
  • Harold H
    Harold H
    2011-12-12

    And now I tested ualertme at work. The problems returned. It only worked once and then I wash't able to TCP/IP connect anymore. Connecting through Bonjour didn't work at all. My iPhone wasn't listed in the networklist.
    I have collected several console messages and in the iPhone diagnostics I see lots of files appearing, both awdd and ualertme. I attached them to this problem record

     
  • Peter Easdown
    Peter Easdown
    2011-12-12

    Thanks for all of the information! I only wish all users were able to provide this much detail!

    Firstly, the crashes in UA are a known issue and have already been fixed in v1.6 which is waiting for Apple's approval process to run it's course.

    FYI, there are instructions on my pkclsoft.com support page (http://www.pkclsoft.com/pkclsoft/Support.html) for getting crash logs from your iPhone. In theory Apple is supposed to send them to me, but their system seems to have the opinion that unless there are masses of crashes it won't pass them through. Useless in other words.

    Secondly, the issue you're having with connectivity is separate to the UA crashes. The problems you seem to be having are that on your home network connections are possible because both the phone and the mac are (I'm guessing) connecting to the same wifi network, so they can see each other. Bonjour is a local network service and doesn't work across the internet unless you set it up right. There are instructions on my website for that at: http://www.pkclsoft.com/pkclsoft/configuringyourmac.html that tell you how to setup the mac for "Wide-Area-Bonjour". There is a link on that page that you should follow to help you out.

    Basically, for your phone to be able to connect to your mac no matter where it is, you will need either a static IP address for your mac (which is pretty unlikely), or you will need to set up a dynamic DNS record. Even then, if the mac is behind a firewall, the iPhone won't be able to connect to it. There's nothing much I can do about that at the moment, though I do have a plan for the future.

    I will look into the "reconnect" issue. It sounds like IA is not resetting it's connection properly after UA disconnects.

    Thanks again for all your help. Please let me know if there are further problems. I'm leaving this ticket open to capture the reconnect issue.

    ezsource

     
  • Harold H
    Harold H
    2011-12-12

    All uAlertMe crash files

     
  • Harold H
    Harold H
    2011-12-12

    Thanks for the compliments. I'm working in problem solving situations myself and I know how valuable information can propel your work considerably.

    Those instruction pages were new to me. I must have missed the links to them somehow. I always go to this site (SF) for all information where I only found a link to http://ialertu.sourceforge.net/

    Some more info about the connection at work: I was connecting my Mac and my iPhone through the same wireless network. Maybe it is difficult for UA to find my Mac in the long list of other Bonjour or network clients?

    If you send me the list of strings that you mentioned, I can look at the Dutch translations for you.

    I have uploaded all my crash logs with the method that you described. Maybe you can use them for solving other problems as well.

    I'm looking forward to all the improvements that you are putting in IA and UA.

     
  • Peter Easdown
    Peter Easdown
    2011-12-13

    I must thankyou again. Those extra crash reports provided some very important details that made it easy to reproduce the reconnection problem. As it turns out the problem is not with IU; rather it is with UA.

    I've fixed it and have resubmitted v1.6 to Apple with the correction.

    Thanks again.

    ezsource

     
  • Peter Easdown
    Peter Easdown
    2012-01-26

    • milestone: --> v0.76
    • status: open-accepted --> closed-fixed
     
  • Peter Easdown
    Peter Easdown
    2012-01-26

    This problem has I believe been resolved by a new release of uAlertMe (v1.6).

     
  • Peter Easdown
    Peter Easdown
    2012-01-26

    • status: closed-fixed --> pending-fixed
     
  • Peter Easdown
    Peter Easdown
    2012-06-20

    • status: pending-fixed --> closed-fixed