Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#142 Unable to build

closed-duplicate
nobody
None
5
2013-03-18
2012-05-27
Anonymous
No

Unable to build because of dependency on gtk+extra, which appears to be abandonware, since no other significant projects anywhere use it. gtk+extra won\'t build on a system with gtk-2.0 installed:

gtkitementry.c:134:21: error: static declaration of ‘gtk_entry_reset_im_context’ follows non-static declaration
/usr/include/gtk-2.0/gtk/gtkentry.h:311:13: note: previous declaration of ‘gtk_entry_reset_im_context’ was here

This is with the LATEST downloaded version of gtk+extra from sourceforge
Please remove the gtk+extra dependency and link to something a little more modern and mainstream so we can use this excellent simulator without having to install something like Red Hat 7.

Discussion

  • Robert Pearce
    Robert Pearce
    2012-05-28

    Simply reasserting the same FUD does not make it true. GTK+Extra 2.1.2 works with GTK-2.0 up to 2.20, and GTK+Extra 3 works with later versions. The project is still maintained and current.

    I'm highly disinclined to respond positively to your offensive and dishonest attitude, Mr. Anonymous, but if you can suggest "something a little more modern" that serves the same purpose, then please do. Nobody on the GTK developer list has been able to.

     


Anonymous


Cancel   Add attachments