#222 fink should use gcc-4.2/g++-4.2 if present

None
closed-wont-fix
nobody
None
5
2013-04-17
2007-12-11
Jack Howarth
No

Now that Apple has released an Xcode 3.0 GCC 4.2 Developer Preview 1 on connect.apple.com, fink should be modified to use these new compilers if present. This would insure that the new compilers are throughly tested before release against as much of fink as possible. I would suggest the following approach. The default behavior should be to use the gcc-4.2/g++-4.2 compilers if present unless the user has either set a flag in the info file to not build that package with them or a system-wide flag in fink.conf not to use them at all on that system.

Discussion

  • Madd the Sane
    Madd the Sane
    2009-04-25

    It is important to remember that GCC 4.2 is only available on 10.5.

     
    • status: open --> closed-wont-fix
    • Group: -->
     
  • Closing as outdated (10.5 could be updated to gcc-4.2, but at this point of the game, there is very little to gain). And newer distros use the latest possible Apple compiler available to them.