#1624 PDB update script should ignore 10.4-EOL on 10.5+

10.5_and_10.6
open
nobody
5
2014-01-17
2011-10-06
Max Horn
No

The information on <http://pdb.finkproject.org/pdb/package.php/mc> is currently incorrect: It claims that 4.7.5.2-1 is the latest unstable version for 10.5 and 10.6, but in reality 4.7.5.5-1 is the latest unstable *and* stable version across all 10.5 configurations.

This is because the PDB script looks at 10.4-EOL/gnome/mc.info for these systems, which contains an old version, and uses that in the database.

But this is wrong:
a) It should not look at 10.4-EOL when generating data for systems 10.5 and upwards
b) It should not let one .info with an old version override the data from another .info with a newer version.

Discussion

    • Group: --> 10.5_and_10.6
     
  • I believe this particular issue (using EOL data to populate non-EOL) was taken care of when Justin restarted the PDB in the new server.
    There are still some quirks though: http://pdb.finkproject.org/pdb/package.php/ffmpeg (the 10.6 entries should read 1.0.8, not 0.8.15). However, that's a separate issue and should be opened as a new bug.