1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #18161 (closed: wontfix)

Opened 3 years ago

Last modified 3 years ago

"Recent activity" list no longer available?

Reported by: axfangli Owned by: ctsai
Keywords: ENGR NF-1674 Cc:
Private: no

Description

I remember that I used to be able to see, from a project's summary page, any files that have been changed recently.

Now, when I'm notified of a file change via RSS, I still need to dig through the "Files" directory to figure out what changed, because the "recent activity" list is gone, and the parent directories' "Modified" date is not updated when its children have been modified.

Is there an easier way to do this?

Change History

Changed 3 years ago by ctsai

  • keywords PEND added; Files, subdirectories, activity removed
  • owner set to ctsai
  • status changed from new to assigned

It seems like a bug to me if the parent directory's "Modified" date isn't updated when its contents change.

I can't seem to reproduce that bug in my test project, do you have an example of this?

Thanks,
Chris Tsai, SourceForge.net Support

Changed 3 years ago by axfangli

Hi Chris,

See http://sourceforge.net/projects/mingw/files/

files/Automated MinGW Installer/ is listed as modified on 2010-11-07, while its child,
files/Automated MinGW Installer/mingw-get/ is listed as modified on 2011-02-26.

Perhaps the directory dates only get updated for child files, but not child directories.

Changed 3 years ago by ctsai

  • keywords ENGR NF-1674 added; PEND removed

Excellent, thank you. I'm escalating this to our engineering team for further review. You can see the ticket I submitted to them here: https://sourceforge.net/p/allura/tickets/1674/

Regards,
Chris Tsai, SourceForge.net Support

Changed 3 years ago by ctsai

  • status changed from assigned to closed
  • resolution set to wontfix

The engineering team has closed that item as "wont-fix" with this explanation:

Yes, directory dates only get updated for immediately child files, not
recursively through directories that are deeper. This is comparable to
most desktop filesystems, and efficient for our file release system.

With that said, the RSS feeds for the files space should have the file release dates so that should help you figure out what files actually changed.

Regards,
Chris Tsai, SourceForge.net Support

Changed 3 years ago by axfangli

Thank you Chris and engineering team, for your fast responses. I understand the efficiency considerations raised by the engineering team, but the root issue still stands: It's difficult to locate an updated file that's deep within a directory tree. If you go to https://sourceforge.net/export/rss2_keepsake.php?group_id=2435 and try to find the files released around 6 March, I'm sure you'll find it a daunting task.

The content of an RSS feed entry is something like this...

2011-03-05 21:15:04 - made 1 file-release changes

...which is very un-descriptive, IMHO. The RSS feed entry also links me to the project summary page, which is far from the file(s) I'm interested in.

Perhaps the RSS feed entries could be improved/expanded? Include a list of links to the updated directories, maybe?

Changed 3 years ago by axfangli

Clarification: The timestamp in the RSS feed isn't very helpful since the top-level directories don't have their "Modified" date updated... i.e. the user will have to find the updated subdirectory by trial-and-error.

Changed 3 years ago by ctsai

The RSS feed I was referring to is the one on the "Files" page, eg. http://sourceforge.net/api/file/index/project-id/2435/mtime/desc/limit/20/rss

(btw, you can change the number after "limit" in the URL to show more entries if you want)

I suspect that that feed satisfy your needs.

Regards,
Chris Tsai, SourceForge.net Support

Changed 3 years ago by axfangli

Ah, it does indeed. Thanks!

Note: See TracTickets for help on using tickets.