1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #14639 (closed: wontfix)

Opened 4 years ago

Last modified 23 months ago

Unwanted project admin deletion

Reported by: foens Owned by: ctsai
Keywords: ENGR AT-467 Cc:
Private: no

Description

Hello SourceForge.

I have just found a small bug in the way that membership is handled. It effectively made me delete a project admin.

First, I wrongly pressed the delete button on an admin. The page told me that Project admins cannot be deleted. That is fine.

I then went to degrade the user to non-admin. When I did this, and the popup window close, the page I was on refreshed. The page I was on was the page that sent the "remove user" command, and since the user was just degraded to non-admin, the user could now be removed.

I think this is a bug as I did not press the remove button afterwards.

Kasper

Change History

Changed 4 years ago by ctsai

  • keywords ENGR AT-467 added
  • owner set to ctsai
  • status changed from new to assigned

Hello,

Thank you for this report, I've confirmed your findings and I'm escalating this to our engineering team for further review.

Regards,
Chris Tsai, SourceForge.net Support

Changed 23 months ago by ctsai

  • status changed from assigned to closed
  • resolution set to wontfix

Greetings,

This issue only affects the classic SourceForge system, which we are no longer developing. As such, I'm closing this ticket as "wontfix".

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.