1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000088 [Pdftoipe] major always 2011-10-16 11:22 2013-01-24 07:31
Reporter pinotree View Status public  
Assigned To Ocheong
Priority normal Resolution fixed  
Status resolved  
Summary 0000088: pdftoipe does not compile with poppler >= 0.18
Description pdftoipe-20110916 does not compile with the new stable serie of poppler, 0.18.0:

$ make
g++ -Wno-write-strings -I/usr/include/poppler -c -o xmloutputdev.o xmloutputdev.cpp
xmloutputdev.cpp: In member function 'virtual void XmlOutputDev::drawImage(GfxState*, Object*, Stream*, int, int, GfxImageColorMap*, GBool, int*, GBool)':
xmloutputdev.cpp:339:13: error: 'DCTStream' was not declared in this scope
xmloutputdev.cpp:339:24: error: expected primary-expression before ')' token
xmloutputdev.cpp:339:25: error: expected ')' before 'str'

There are two problems:
a) the code assumes DCTStream is declared in Stream.h (which is only when poppler is compiled with an own JPEG decoder, instead of using libjpeg)
b) getRawStream() has been removed, since it was the very same as getNextStream()

The attached patch fixes both the issues by making use of getNextStream(), which is declared in the base Stream class, hence no more cast is required.

The patch makes pdftoipe compile also on older poppler versions (e.g. 0.12.x).
Additional Information
Tags No tags attached.
Attached Files ? file icon poppler.diff [^] (312 bytes) 2011-10-16 11:22

- Relationships

-  Notes
(0000315)
pinotree (reporter)
2012-07-15 19:41

Any news about this bug?
(0000322)
Ocheong (administrator)
2013-01-24 07:31

Fixed in 2013-01-24.

- Issue History
Date Modified Username Field Change
2011-10-16 11:22 pinotree New Issue
2011-10-16 11:22 pinotree File Added: poppler.diff
2012-01-15 23:33 Ocheong Status new => assigned
2012-01-15 23:33 Ocheong Assigned To => Ocheong
2012-07-15 19:41 pinotree Note Added: 0000315
2013-01-24 07:31 Ocheong Note Added: 0000322
2013-01-24 07:31 Ocheong Status assigned => resolved
2013-01-24 07:31 Ocheong Resolution open => fixed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker