Thank you very much, also for the reference to the relevant RFC.
Perfect, thank you very much.
Hello, when we receive a MDN from a specific partner, the MIC algorithm string does not exactly match the string we're sending. Message was sent but an error occured while receiving the MDN: MIC algorithm returned by partner is not the same as the algorithm requested but must be the same per RFC4130 section 7.4.3. Original MIC alg: sha256 ::: returned MIC alg: sha2_256 We're sending sha256, they're sending back sha2_256, this produces an error. The questions I have: 1. Is what they're doing incorrect?...
Issue is solved, the other party had a misconfiguration. Thank you very much as always.
Hello, I'm trying to set up a new partner in OpenAS2 v2.9.0. While sending test files to check the connection, the partner AS2 server has an error: Message not signed by certificate with common name [null] In particular on my end: FINE AS2SenderModule: Connecting to: http://... FINE AS2SenderModule: Message sent and response received in 1044 millisecondsms FINE AS2Util: received MDN [automatic-action/MDN-sent-automatically; processed/Error: authentication-failed] WARNING AS2Util: Disposition exception...
Hello, I'm trying to set up a new partner in OpenAS2 v2.9.0. While sending test files to check the connection, the partner AS2 server has an error: Message not signed by certificate with common name [null] In particular on my end: `FINE AS2SenderModule: Connecting to: http://... FINE AS2SenderModule: Message sent and response received in 1044 millisecondsms FINE AS2Util: received MDN [automatic-action/MDN-sent-automatically; processed/Error: authentication-failed] WARNING AS2Util: Disposition exception...
True, if they can decrypt and verify my message, certificates have to be in place. I also agree that there seems to be a mixup with SHA1 and SHA256. I've also set up another server and deliberately set the wrong cert on the receiver end to compare the resulting errors. In any case, this was the testing environment. Meanwhile, the production environment communication was set up and everything is working perfectly. So while the problem is still there, its not of any concern anymore. Thank you very...
Thank you for noticing. Yes, I have several working partnerships using the same certificate. Edit; Would you also say that everything points to the wrong certificate being used on the Receiver?