Well, I can't explain it but it's working now. I haven't changed anything but I have removed and reconnected the irdroid device a few times in troubleshooting. I found clues in some forum posts that error 31 is "A device attached to the system is not functioning" but I haven't found documentation to back that up. In any case, it seems that removing and reconnecting may have helped - back to hardware or firmware issues. Thanks for your time in working to help me and in maintaining the package. Da...
Ian, I removed the breaking plugins from the solution and got it to build. I'm using Visual Studio 2015. The offending line is in the IRToy project, serial.cpp line 358: if (!::SetCommState(m_hFile,&dcb)) SetCommState is setting error 31 - for which I have not been able to find any documentation. But the error is coming from the Win32 API call and probably based on a hardware issue in my IR adapter from irdroid. Since I am using an IRToy clone, I'm kind of stuck. I ordered a real IRToy but that won't...
It's set to com3, which is the same identified in device manager. I've downloaded the source to try to add some debugging and logging info to see if I can find out what's happening but the trunk does not build; there are a lot of errors. Many instances lf: invalid literal suffix 'L'; literal operator or literal operator template 'operator ""L' not found. A few instances of unresolved external symbols, and a couple of symbols defined more than once. Most of those, but not all, are in plugins I don't...
I deleted the config file and it still doesn't init. I deleted the .ini file and still won't init. I ran irrecord again and created a new config file from a different remote and tried configuring that config file and still won't init.
Adding config file attachment.
Trying to add attachments.
failed to initialize error
I solved my issue. It appears that VcXsrv is unpredictable about which NIC/IP-address to which it will bind. On my work pc, last week it worked on the DockerNat address. Today that didn't work. When I troubleshot it I found that VcXsrv had bound to the Hyper-V HNS NAT instead. Weird. So when I got home I checked my home laptop and it turns out that VcXsrv hadn't bound to either the Docker NAT or the HNS NAT. It had, instead, bound to the main WIFI on my laptop at 192.168.43.7. Once I bound the DISPLAY=192.168.43.7:0.0...