TekSIP

TekSIP

KaplanSoft
+
+

Related Products

  • HiveMQ
    92 Ratings
    Visit Website
  • Statseeker
    35 Ratings
    Visit Website
  • CEX.IO
    29 Ratings
    Visit Website
  • Code-Cube.io
    7 Ratings
    Visit Website
  • EZO AssetSonar
    118 Ratings
    Visit Website
  • Shoplogix Smart Factory Platform
    19 Ratings
    Visit Website
  • RXNT
    552 Ratings
    Visit Website
  • Splashtop Autonomous Endpoint Management
    402 Ratings
    Visit Website
  • Aircall
    1,838 Ratings
    Visit Website
  • Sogolytics
    869 Ratings
    Visit Website

About

Enterprises running real-time web and mobile apps struggle with latency, bandwidth, and scalability issues, which negatively impact the total cost of ownership as well as the real-time experience of their users. These issues are inherent to the traditional techniques, such as HTTP polling or long polling, employed to achieve real-time communication using web and application servers. To overcome these issues, we created MigratoryData, a real-time messaging technology leveraging the WebSockets standard, streaming data to and from users over persistent WebSocket connections in milliseconds and with minimal traffic overhead. Unlike other real-time messaging technologies, MigratoryData has been designed to scale to a large number of users. It has been benchmarked to stream real-time data to 10 million concurrent users from a single commodity server.

About

TekSIP is a SIP Registrar and SIP Proxy for Windows. TekSIP supports UDP, TCP, TLS and WebSocket (IPv4 & IPv6) transports. TLS and Secure WebSocket are supported in only commercial editions. TekSIP is tested on Microsoft Windows Vista, Windows 7/8/10/11 and Windows 2008-2022 server. TekSIP can be deployed as a signaling server for WebRTC based SIP phones. TekSIP complies with RFC 3261, RFC 3263, RFC 3311, RFC 3581 and RFC 3891. It supports NAT traversal and ENUM. Please see technical details about NAT traversal in Readme. You can select IP address to be listened and alternative SIP endpoints for outgoing calls. You can also log session details into a log file and monitor active registrations and sessions in real-time. You can monitor number of active registrations and sessions using Windows Performance Monitor (Perfmon.exe). TekSIP can redirect calls to alternate endpoint when called endpoint is unavailable (Off-line, busy...). Active SIP session can be terminated via GUI.

Platforms Supported

Windows Not Supported
Mac Not Supported
Linux Not Supported
Cloud Supported
On-Premises Not Supported
iPhone Not Supported
iPad Not Supported
Android Not Supported
Chromebook Not Supported

Platforms Supported

Windows Supported
Mac Not Supported
Linux Not Supported
Cloud Not Supported
On-Premises Supported
iPhone Not Supported
iPad Not Supported
Android Not Supported
Chromebook Not Supported

Audience

Businesses searching for a scalable web messaging solution, commonly used for real-time web and mobile apps

Audience

Enterprise, Service Providers, Utility Companies

Support

Phone Support Not Supported
24/7 Live Support Not Supported
Online Supported

Support

Phone Support Supported
24/7 Live Support Supported
Online Supported

API

Offers API Supported

API

Offers API Supported

Screenshots and Videos

Screenshots and Videos

Pricing

No information available.
Free Version Not Supported
Free Trial Not Supported

Pricing

$239
Freeware version allows maximum 3 SIP endpoints registration and 3 simultaneous SIP sessions. Enterprise edition allows upto 100 simultaneous registration and SIP sessions. Following features are not supported in free edition;

Enterprise
* SDP Manipulation
* TLS Transport
* SMPP Gateway

SP
* Enterprise features
* External Authenticator
* SRTP -> RTP interworking
* WebRTC Media Gateway
* Unlimited number of simultaneous SIP registrations and sessions
* Route incoming calls to registered extensions
* IPv6 support
* RADIUS AAA
Free Version Supported
Free Trial Supported

Reviews/Ratings

Overall 0.0 / 5
ease 0.0 / 5
features 0.0 / 5
design 0.0 / 5
support 0.0 / 5

This software hasn't been reviewed yet. Be the first to provide a review:

Review this Software

Reviews/Ratings

Overall 0.0 / 5
ease 0.0 / 5
features 0.0 / 5
design 0.0 / 5
support 0.0 / 5

This software hasn't been reviewed yet. Be the first to provide a review:

Review this Software

Training

Documentation Supported
Webinars Not Supported
Live Online Not Supported
In Person Not Supported

Training

Documentation Supported
Webinars Not Supported
Live Online Supported
In Person Not Supported

Company Information

MigratoryData
migratorydata.com/products/migratorydata/

Company Information

KaplanSoft
Founded: 2011
Turkey
www.kaplansoft.com

Alternatives

ejabberd

ejabberd

ProcessOne

Alternatives

TekIVR

TekIVR

KaplanSoft
TekRADIUS

TekRADIUS

KaplanSoft
AliwareMQ for IoT

AliwareMQ for IoT

Alibaba Cloud
websockets

websockets

Python Software Foundation

Categories

Message Queue Supported

Categories

Telephony Supported

Telephony Features

Auto-Dialer Not Supported
Call Center Management Not Supported
Call Monitoring Supported
Contact Management Not Supported
Inbound Reporting Not Supported
IVR / Voice Recognition Not Supported
Outbound Reporting Not Supported
Predictive Dialer Not Supported
Telemarketing Management Not Supported
Voice & Data Integration Supported
VoIP Supported

Integrations

Apache Kafka Supported
TekRADIUS Not Supported

Integrations

Apache Kafka Not Supported
TekRADIUS Supported
Claim MigratoryData and update features and information
Claim MigratoryData and update features and information
Claim TekSIP and update features and information
Claim TekSIP and update features and information