Menu ▾ ▴

#94 User Creation Issue with LDAP

v 2.0.x
open
nobody
None
5
2014-02-27
2013-10-16
No

I tried to setup LDAP authentication in WebPA but the site kept returning the following message:

Your username and password were rejected.

Upon investigating, I discovered an issue with the creation of users in WebPA given information from the LDAP server. If LDAP__AUTO_CREATE_USER == true the code tries to execute an SQL Insert statement which attempts to set the 'user_type' in the pa2_user table. The problem is this column was removed from the users table when moving from version 1 to 2. As a result, I believe LDAP authentication will not work for any instances of version 2 of WebPA.

Related

Bugs: #94

Discussion

  • Troels Bugge

    Troels Bugge - 2014-02-27

    Hi Andrew,
    Have you solved this problem or maybe found a quickfix? I have the same problem as you - our users cannot authenticate with LDAP and get the error "Your username and password were rejected".

    Thank you,

    Troels

     
    • Andrew Millington

      Hi Troels,

      I tried to create a fix for this issue but there are numerous issues tied
      into the problem so it became a bit of a rats nest. I decided it would take
      too long for me to fix so just relied on Blackboard authentication for our
      students. I haven't heard anything from the WebPA devs since posting the
      bug,

      All the best,

      Andrew
      On 27 Feb 2014 15:55, "Troels Bugge" troelsbugge@users.sf.net wrote:

      Hi Andrew,
      Have you solved this problem or maybe found a quickfix? I have the same
      problem as you - our users cannot authenticate with LDAP and get the error
      "Your username and password were rejected".

      Thank you,

      Troels

      Status: open
      Created: Wed Oct 16, 2013 04:37 PM UTC by Andrew Millington
      Last Updated: Wed Oct 16, 2013 04:37 PM UTC
      Owner: nobody

      I tried to setup LDAP authentication in WebPA but the site kept returning
      the following message:

      Your username and password were rejected.

      Upon investigating, I discovered an issue with the creation of users in
      WebPA given information from the LDAP server. If LDAP__AUTO_CREATE_USER ==
      true the code tries to execute an SQL Insert statement which attempts to
      set the 'user_type' in the pa2_user table. The problem is this column was
      removed from the users table when moving from version 1 to 2. As a result,
      I believe LDAP authentication will not work for any instances of version 2
      of WebPA.


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/webpa/bugs/94/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #94


Log in to post a comment.